kernel: bump 4.14 to 4.14.37
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 26 Apr 2018 16:20:36 +0000 (18:20 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Mon, 30 Apr 2018 06:07:53 +0000 (09:07 +0300)
Refreshed all patches

Compile-tested on: cns3xxx, imx6, octeon, ramips/mt7621, x86/64
Runtime-tested on: cns3xxx, imx6, octeon, ramips/mt7621, x86/64

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Tested-by: Stijn Segers <foss@volatilesystems.org>
[add extra tested targets to commit msg]
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
include/kernel-version.mk
target/linux/generic/backport-4.14/336-netfilter-exit_net-cleanup-check-added.patch
target/linux/generic/pending-4.14/610-netfilter_match_bypass_default_checks.patch

index 8d0a62347cbfc460106d0a74168882ad7a4ef2ef..cf84e31f7b0f962a64633694ffdf08fe6f8383d5 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
 LINUX_VERSION-4.9 = .96
-LINUX_VERSION-4.14 = .36
+LINUX_VERSION-4.14 = .37
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
 LINUX_KERNEL_HASH-4.9.96 = 826f596eb5197f8b17304649c2990dd7b766f5c79076cae79f4261c40cea877f
-LINUX_KERNEL_HASH-4.14.36 = cae24404d7b5812a331cbbc430b3ab75ca0f76eb16803528cbffbc42e768bc43
+LINUX_KERNEL_HASH-4.14.37 = 8197e7ed3620713e412905430a7bf93e2048384042ffba189a66f0eeb6908e92
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 92d7942d868476e4774cb490ef2881e6767ac350..d930751d415fff1832f4e9f86daa6ba19256c2e5 100644 (file)
@@ -80,7 +80,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static void nfnl_queue_net_exit_batch(struct list_head *net_exit_list)
 --- a/net/netfilter/x_tables.c
 +++ b/net/netfilter/x_tables.c
-@@ -1754,8 +1754,17 @@ static int __net_init xt_net_init(struct
+@@ -1785,8 +1785,17 @@ static int __net_init xt_net_init(struct
        return 0;
  }
  
index ec269b6cd880ff1cea1027e5cdf78be3f6f07337..36118796094dfacfd84b9817a422d1abcada0dd2 100644 (file)
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
                     i += m->u.match_size) {
-@@ -1224,12 +1261,15 @@ compat_copy_entry_to_user(struct ipt_ent
+@@ -1226,12 +1263,15 @@ compat_copy_entry_to_user(struct ipt_ent
        compat_uint_t origsize;
        const struct xt_entry_match *ematch;
        int ret = 0;