iptables: refresh patches
authorFelix Fietkau <nbd@openwrt.org>
Wed, 2 Jul 2014 19:18:09 +0000 (19:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 2 Jul 2014 19:18:09 +0000 (19:18 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 41479

package/network/utils/iptables/patches/020-iptables-disable-modprobe.patch
package/network/utils/iptables/patches/030-no-libnfnetlink.patch

index ad4889b706557a45f8bac397ddb0e38fbf4d3abf..2b6c57ec9e6c2d832b276c8ffb26ecce76ad6e5e 100644 (file)
@@ -8,7 +8,7 @@
        char *buf = NULL;
        char *argv[4];
        int status;
        char *buf = NULL;
        char *argv[4];
        int status;
-@@ -380,6 +381,7 @@ int xtables_insmod(const char *modname,
+@@ -380,6 +381,7 @@ int xtables_insmod(const char *modname, 
        free(buf);
        if (WIFEXITED(status) && WEXITSTATUS(status) == 0)
                return 0;
        free(buf);
        if (WIFEXITED(status) && WEXITSTATUS(status) == 0)
                return 0;
index ac825e9b21015cdc39dc6ea7a5a657b93fbd15ca..50542ac0b50065d921c31422a0a41c31c44871b3 100644 (file)
@@ -1,11 +1,9 @@
-Index: iptables-1.4.19.1/configure
-===================================================================
---- iptables-1.4.19.1.orig/configure   2013-05-29 16:37:33.176674855 +0200
-+++ iptables-1.4.19.1/configure        2013-05-29 16:37:33.168674855 +0200
-@@ -12198,77 +12198,7 @@
-       fi
+--- a/configure
++++ b/configure
+@@ -12367,77 +12367,7 @@ fi
  fi
  
  fi
  
 -pkg_failed=no
 -{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnfnetlink" >&5
 -$as_echo_n "checking for libnfnetlink... " >&6; }
 -pkg_failed=no
 -{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnfnetlink" >&5
 -$as_echo_n "checking for libnfnetlink... " >&6; }
@@ -81,13 +79,11 @@ Index: iptables-1.4.19.1/configure
    HAVE_LIBNFNETLINK_TRUE=
    HAVE_LIBNFNETLINK_FALSE='#'
  else
    HAVE_LIBNFNETLINK_TRUE=
    HAVE_LIBNFNETLINK_FALSE='#'
  else
-Index: iptables-1.4.19.1/configure.ac
-===================================================================
---- iptables-1.4.19.1.orig/configure.ac        2013-05-29 16:37:33.176674855 +0200
-+++ iptables-1.4.19.1/configure.ac     2013-05-29 16:37:33.168674855 +0200
-@@ -93,9 +93,7 @@
- AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])
- AM_CONDITIONAL([ENABLE_BPFC], [test "$enable_bpfc" = "yes"])
+--- a/configure.ac
++++ b/configure.ac
+@@ -111,9 +111,7 @@ if test "x$enable_bpfc" = "xyes" || test
+       AC_CHECK_LIB(pcap, pcap_compile,, AC_MSG_ERROR(missing libpcap library required by bpf compiler or nfsynproxy tool))
+ fi
  
 -PKG_CHECK_MODULES([libnfnetlink], [libnfnetlink >= 1.0],
 -      [nfnetlink=1], [nfnetlink=0])
  
 -PKG_CHECK_MODULES([libnfnetlink], [libnfnetlink >= 1.0],
 -      [nfnetlink=1], [nfnetlink=0])