kernel: add kmod-rtc-pcf2127
authorRobert Marko <robimarko@gmail.com>
Wed, 16 May 2018 18:00:15 +0000 (20:00 +0200)
committerLuka Perkov <luka.perkov@sartura.hr>
Sun, 6 Oct 2019 19:26:11 +0000 (21:26 +0200)
Add kernel module to support NXP PCF2127 and PCF2129 RTC clocks.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/linux/modules/other.mk

index e98b8a9223fbd3635f0bb07c1d8b35752db40efb..3abd1f48f6169366f6e059f19ce9107f8e7a38f0 100644 (file)
@@ -599,6 +599,22 @@ endef
 
 $(eval $(call KernelPackage,rtc-pcf2123))
 
 
 $(eval $(call KernelPackage,rtc-pcf2123))
 
+define KernelPackage/rtc-pcf2127
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=NXP PCF2127 and PCF2129 RTC support
+  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+  KCONFIG:=CONFIG_RTC_DRV_PCF2127 \
+       CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2127.ko
+  AUTOLOAD:=$(call AutoProbe,rtc-pcf2127)
+endef
+
+define KernelPackage/rtc-pcf2127/description
+ Kernel module for NXP PCF2127 and PCF2129 RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-pcf2127))
+
 define KernelPackage/rtc-pt7c4338
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Pericom PT7C4338 RTC support
 define KernelPackage/rtc-pt7c4338
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Pericom PT7C4338 RTC support