kernel: fix packaging of kmod-gpio-nxp-74hc164
authorJo-Philipp Wich <jo@mein.io>
Wed, 3 Jan 2018 12:13:10 +0000 (13:13 +0100)
committerJo-Philipp Wich <jo@mein.io>
Sun, 7 Jan 2018 11:33:47 +0000 (12:33 +0100)
The NXP 74HC164 GPIO expander driver uses a different config symbol
("CONFIG_GPIO_74X164") and module name since since at least Kernel
version 2.6.37.

Update the kmod package definition accordingly by adjusting kconfig
and module file names.

This unrelated, but correct change has been separated from the
WNR2000v5 support commits.

Ref: https://github.com/lede-project/source/pull/1256
Suggested-by: Raphael Catolino <raphael.catolino@gmail.com>
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/other.mk

index 1c7869e7c6758bc67bf4a8a867103a8c83331f80..973e4f3e26a57c5d979afe0e9c43796e3ce46188 100644 (file)
@@ -242,9 +242,9 @@ $(eval $(call KernelPackage,gpio-mcp23s08))
 define KernelPackage/gpio-nxp-74hc164
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NXP 74HC164 GPIO expander support
 define KernelPackage/gpio-nxp-74hc164
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NXP 74HC164 GPIO expander support
-  KCONFIG:=CONFIG_GPIO_NXP_74HC164
-  FILES:=$(LINUX_DIR)/drivers/gpio/nxp_74hc164.ko
-  AUTOLOAD:=$(call AutoProbe,nxp_74hc164)
+  KCONFIG:=CONFIG_GPIO_74X164
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-74x164.ko
+  AUTOLOAD:=$(call AutoProbe,gpio-74x164)
 endef
 
 define KernelPackage/gpio-nxp-74hc164/description
 endef
 
 define KernelPackage/gpio-nxp-74hc164/description