uboot-lantiq: fix build issue
authorFelix Fietkau <nbd@nbd.name>
Sun, 22 Jan 2017 14:04:04 +0000 (15:04 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 22 Jan 2017 14:14:54 +0000 (15:14 +0100)
Do not reference BIN_DIR in the package install section directly, use
$(1) instead.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/uboot-lantiq/Makefile

index cbebe91c2e7cd23ddb605742c7c358ccceb8ac48..401e77ab8e352c8e9a67a5663ed32f3059494609 100644 (file)
@@ -402,9 +402,10 @@ define Build/Compile
 endef
 
 define Package/uboot/install/default
 endef
 
 define Package/uboot/install/default
+       $(INSTALL_DIR) $$(1)
        $(CP) \
                $(PKG_BUILD_DIR)/$(2) \
        $(CP) \
                $(PKG_BUILD_DIR)/$(2) \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.img
+               $$(1)/openwrt-$(BOARD)-$(1)-u-boot.img
 endef
 
 define Package/uboot/install/uart
 endef
 
 define Package/uboot/install/uart
@@ -413,7 +414,7 @@ define Package/uboot/install/uart
                > $(PKG_BUILD_DIR)/ddr_settings
        perl $(PKG_BUILD_DIR)/tools/gct.pl \
                $(PKG_BUILD_DIR)/ddr_settings $(PKG_BUILD_DIR)/u-boot.srec \
                > $(PKG_BUILD_DIR)/ddr_settings
        perl $(PKG_BUILD_DIR)/tools/gct.pl \
                $(PKG_BUILD_DIR)/ddr_settings $(PKG_BUILD_DIR)/u-boot.srec \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.asc
+               $$(1)/openwrt-$(BOARD)-$(1)-u-boot.asc
  endef
 
 define Package/uboot/install/template
  endef
 
 define Package/uboot/install/template