scons: override the platform instead of using the host one - fixes build issues on...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 5 May 2012 21:02:35 +0000 (21:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 5 May 2012 21:02:35 +0000 (21:02 +0000)
SVN-Revision: 31620

include/scons.mk
tools/scons/patches/001-platform_env.patch [new file with mode: 0644]

index 223aedefaf6ae68eb060d100c3857e4a14c8cf50..5062681d63cc0e0113ea790812c5f9aac2f6a9b7 100644 (file)
@@ -1,3 +1,5 @@
+export PLATFORM=posix
+
 SCONS_VARS = \
        CC="$(TARGET_CC)" \
        CXX="$(TARGET_CXX)" \
diff --git a/tools/scons/patches/001-platform_env.patch b/tools/scons/patches/001-platform_env.patch
new file mode 100644 (file)
index 0000000..8aab904
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/engine/SCons/Platform/__init__.py
++++ b/engine/SCons/Platform/__init__.py
+@@ -63,6 +63,8 @@ def platform_default():
+     care about the machine architecture.
+     """
+     osname = os.name
++    if 'PLATFORM' in os.environ:
++        return os.environ['PLATFORM']
+     if osname == 'java':
+         osname = os._osType
+     if osname == 'posix':