mediatek: activate fpu feature flag
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 9 Feb 2018 23:52:20 +0000 (00:52 +0100)
committerJohn Crispin <john@phrozen.org>
Sun, 11 Feb 2018 15:42:28 +0000 (16:42 +0100)
The arm CPUs uses in the supported Mediatket SoCs have a FPU accordingly
to the datasheet, activate it also. The CPU subtype "neon-vfpv4" is
selected, but the toolcahin generated for this SoC will still be
compiled with soft float and not with the hard float ABI as we haven't
the fpu feature flag set. If this toolchain is reused by other targets
this will even affect other targets.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/mediatek/Makefile

index 4ebac09a6e96bdd58d1e4d3ee848d7b226b97555..6824111d85ecfdf976e871927a486f8429acaa6d 100644 (file)
@@ -6,7 +6,7 @@ ARCH:=arm
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
 SUBTARGETS:=32
-FEATURES:=squashfs nand ubifs
+FEATURES:=squashfs nand ubifs fpu
 MAINTAINER:=John Crispin <john@phrozen.org>
 
 KERNEL_PATCHVER:=4.9