kernel: Update kernel 4.14 to version 4.14.193
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 7 Aug 2020 13:49:42 +0000 (15:49 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 8 Aug 2020 15:20:37 +0000 (17:20 +0200)
Compile and runtime tested on x86/64.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
12 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/hack-4.14/221-module_exports.patch
target/linux/generic/pending-4.14/810-pci_disable_common_quirks.patch
target/linux/mediatek/patches-4.14/0127-usb-xhci-mtk-use-ports-count-from-xhci-in-xhci_mtk_s.patch
target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch
target/linux/mediatek/patches-4.14/0199-thermal-mtk-Cleanup-unused-defines.patch
target/linux/mediatek/patches-4.14/0200-thermal-mediatek-add-support-for-MT7622-SoC.patch
target/linux/ramips/patches-4.14/0069-awake-rt305x-dwc2-controller.patch

index 3caa941b72510c4cccee0e20364d1e67b2ae0d4c..9602912bdb934ff854d4f9c7495c5a982733f50b 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .229
-LINUX_VERSION-4.14 = .187
+LINUX_VERSION-4.14 = .193
 
 LINUX_KERNEL_HASH-4.9.229 = 3256c2835fd95a1a739603e78b02d363eac2ce73a39fa19b13b32da4fc370fdc
-LINUX_KERNEL_HASH-4.14.187 = 5b223475eaeea196aa7e127d3f253bca5c35d8afdc72ca75230ce1ecdd1454bd
+LINUX_KERNEL_HASH-4.14.193 = 0b0fb41d4430e1a42738b341cbfd2f41951aa5cd02acabbd53f076119c8b9f03
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 8e405b3af135153d23194b6dc7389ccbcb4f52a6..b00393e8d75a09638e7dab5aa20ee1790468f7a9 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -269,6 +271,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -272,6 +274,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -307,6 +761,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -310,6 +764,22 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
        driver = (struct hc_driver *)id->driver_data;
  
        /* For some HW implementation, a XHCI reset is just not enough... */
-@@ -368,6 +838,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -371,6 +841,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
index a098c4416c552eb255010a6e0dd947d2d8a36aca..4f6f5d2cfad5985410d8ff6fbedcdf9da268f177 100644 (file)
@@ -65,7 +65,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
         * Before updating sk_refcnt, we must commit prior changes to memory
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1697,7 +1697,7 @@ u32 tcp_tso_autosize(const struct sock *
+@@ -1699,7 +1699,7 @@ u32 tcp_tso_autosize(const struct sock *
  {
        u32 bytes, segs;
  
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2215,7 +2215,7 @@ static bool tcp_small_queue_check(struct
+@@ -2217,7 +2217,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
index 2e08e514b7236c5bfd7a92443a22e6528448dafb..0e6aa87f9dfe49d0d436610399a237d0f5358355 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1987,7 +1987,8 @@ static const struct usb_device_id option
+@@ -1990,7 +1990,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index b69d8a01d631e591ce06e68f99e6e19a1a9c7804..6a4475fc6e1e4c8b0420e57c1cf755da760a7ae8 100644 (file)
@@ -238,7 +238,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Data section helpers
-@@ -496,7 +497,7 @@
+@@ -497,7 +498,7 @@
  #define ENTRY_TEXT                                                    \
                ALIGN_FUNCTION();                                       \
                VMLINUX_SYMBOL(__entry_text_start) = .;                 \
@@ -247,7 +247,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
                VMLINUX_SYMBOL(__entry_text_end) = .;
  
  #define IRQENTRY_TEXT                                                 \
-@@ -603,7 +604,7 @@
+@@ -604,7 +605,7 @@
        . = ALIGN(sbss_align);                                          \
        .sbss : AT(ADDR(.sbss) - LOAD_OFFSET) {                         \
                *(.dynsbss)                                             \
index 250bf1180f0c85e4231ffcb0b8730f3440f23f25..003175c2236980973b7bc3981654f4b08aecaf3a 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #include <linux/export.h>
  
  /* Align . to a 8 byte boundary equals to maximum function alignment. */
-@@ -341,14 +351,14 @@
+@@ -342,14 +352,14 @@
        /* Kernel symbol table: Normal symbols */                       \
        __ksymtab         : AT(ADDR(__ksymtab) - LOAD_OFFSET) {         \
                VMLINUX_SYMBOL(__start___ksymtab) = .;                  \
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                VMLINUX_SYMBOL(__stop___ksymtab_gpl) = .;               \
        }                                                               \
                                                                        \
-@@ -410,7 +420,7 @@
+@@ -411,7 +421,7 @@
                                                                        \
        /* Kernel symbol table: strings */                              \
          __ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) {       \
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -793,6 +803,8 @@
+@@ -796,6 +806,8 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \
index 718b8addd4430e8d7c58e930125ea9d69d9fd0d7..1d10af647f1b851ca813e51bc417ad5a6ea5e5ec 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /* The Mellanox Tavor device gives false positive parity errors
   * Mark this device with a broken_parity_status, to allow
   * PCI scanning code to "skip" this now blacklisted device.
-@@ -3095,6 +3096,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -3108,6 +3109,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
  
@@ -40,7 +40,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Ivytown NTB BAR sizes are misreported by the hardware due to an erratum.  To
-@@ -3151,6 +3153,8 @@ static void fixup_debug_report(struct pc
+@@ -3164,6 +3166,8 @@ static void fixup_debug_report(struct pc
        }
  }
  
@@ -49,7 +49,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /*
   * Some BIOS implementations leave the Intel GPU interrupts enabled,
   * even though no one is handling them (f.e. i915 driver is never loaded).
-@@ -3189,6 +3193,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
+@@ -3202,6 +3206,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
  
index f17da7003fcfdfc9fa7015d3a64dcde0b7c94ad4..3ead12e8082de6bef4ccef8552243751c66e7c85 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/drivers/usb/host/xhci-mtk-sch.c
 +++ b/drivers/usb/host/xhci-mtk-sch.c
-@@ -289,12 +289,13 @@ static bool need_bw_sch(struct usb_host_
+@@ -293,12 +293,13 @@ static bool need_bw_sch(struct usb_host_
  
  int xhci_mtk_sch_init(struct xhci_hcd_mtk *mtk)
  {
index df099ea3f3b0011217e05a1d459b5b93226eb106..32b4e636800ae1f4e9f79a945a363c084484c47d 100644 (file)
@@ -86,7 +86,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        if (!xhci->shared_hcd) {
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -280,6 +280,9 @@ static int xhci_pci_setup(struct usb_hcd
+@@ -283,6 +283,9 @@ static int xhci_pci_setup(struct usb_hcd
        if (!xhci->sbrn)
                pci_read_config_byte(pdev, XHCI_SBRN_OFFSET, &xhci->sbrn);
  
index af910a66607c591d106ad352d5637c2fe0905fe8..a7288acdf1f4f76406b56b94f5752971fd31b98c 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Eduardo Valentin <edubezval@gmail.com>
  struct mtk_thermal;
  
  struct thermal_bank_cfg {
-@@ -767,7 +760,7 @@ static struct platform_driver mtk_therma
+@@ -765,7 +758,7 @@ static struct platform_driver mtk_therma
        .probe = mtk_thermal_probe,
        .remove = mtk_thermal_remove,
        .driver = {
index 1dc293641ede39962f79e5504baf5c162653e831..731bd163d87857209f504afb0fe473f9d738e9f5 100644 (file)
@@ -68,7 +68,7 @@ Signed-off-by: Shunli Wang <shunli.wang@mediatek.com>
  /**
   * raw_to_mcelsius - convert a raw ADC value to mcelsius
   * @mt:               The thermal controller
-@@ -633,6 +664,10 @@ static const struct of_device_id mtk_the
+@@ -631,6 +662,10 @@ static const struct of_device_id mtk_the
        {
                .compatible = "mediatek,mt2712-thermal",
                .data = (void *)&mt2712_thermal_data,
index 0e09e1d4e0db66060faa61cd57408e312ac3ed1c..e75d19dfce8c0c4aa8f6035177d398a620efa865 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/dwc2/platform.c
 +++ b/drivers/usb/dwc2/platform.c
-@@ -406,6 +406,12 @@ static int dwc2_driver_probe(struct plat
+@@ -407,6 +407,12 @@ static int dwc2_driver_probe(struct plat
        if (retval)
                return retval;