uboot-mvebu: switch to u-boot.mk
authorFelix Fietkau <nbd@nbd.name>
Mon, 23 Jan 2017 11:09:10 +0000 (12:09 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 24 Jan 2017 15:21:24 +0000 (16:21 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/uboot-mvebu/Makefile
package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch [deleted file]
target/linux/mvebu/image/Makefile
target/linux/mvebu/profiles/000-Default.mk

index 0242309462129492812e637502b64cb1a06bd869..e0cd944be93b6af523589fe139545c510b77cf06 100644 (file)
@@ -8,90 +8,31 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_NAME:=u-boot
 PKG_VERSION:=2016.03
 PKG_RELEASE:=1
 
 PKG_VERSION:=2016.03
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=\
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
 PKG_HASH:=e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb
 
 PKG_HASH:=e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb
 
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
-
-PKG_BUILD_PARALLEL:=1
-
+include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
 include $(INCLUDE_DIR)/package.mk
 
-define uboot/Default
-  TITLE:=
-endef
-
-define uboot/clearfog
-  TITLE:=U-Boot for SolidRun ClearFog A1
-  DEVICE:=armada-388-clearfog
-endef
-
-UBOOTS:= \
-       clearfog
-
-define Package/uboot/template
-define Package/uboot-mvebu-$(1)
-  SECTION:=boot
-  CATEGORY:=Boot Loaders
-  DEPENDS:=@(TARGET_DEVICE_mvebu_DEVICE_$(3)||TARGET_mvebu_DEVICE_$(3)||TARGET_mvebu_Default)
-  DEFAULT:=m
+define U-Boot/Default
+  BUILD_TARGET:=mvebu
   HIDDEN:=1
   HIDDEN:=1
-  TITLE:=$(2)
-  URL:=http://www.denx.de/wiki/U-Boot
-  VARIANT:=$(1)
-  MAINTAINER:=Felix Fietkau <nbd@nbd.name>
-endef
 endef
 
 endef
 
-define BuildUBootPackage
-       $(eval $(uboot/Default))
-       $(eval $(uboot/$(1)))
-       $(call Package/uboot/template,$(1),$(TITLE),$(DEVICE))
+define U-Boot/clearfog
+  NAME:=SolidRun ClearFog A1
+  BUILD_DEVICES:=armada-388-clearfog
+  UBOOT_IMAGE:=u-boot-spl.kwb
 endef
 
 endef
 
-define Build/Configure
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               $(BUILD_VARIANT)_config
-endef
-
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE=$(TARGET_CROSS) \
-               DTC_DIR=$(LINUX_DIR)/scripts/dtc/
-endef
+UBOOT_TARGETS:= \
+       clearfog
 
 
-define Package/uboot/install/default
-       $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
-       $(CP) $(PKG_BUILD_DIR)/u-boot-spl.kwb \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-spl.kwb
+define Build/InstallDev
        $(INSTALL_DIR) $(KERNEL_BUILD_DIR)/
        $(INSTALL_DIR) $(KERNEL_BUILD_DIR)/
-       $(CP) $(PKG_BUILD_DIR)/u-boot-spl.kwb \
-               $(KERNEL_BUILD_DIR)/openwrt-$(BOARD)-$(1)-u-boot-spl.kwb
-       $(INSTALL_DIR) $(BIN_DIR)/u-boot-kwboot/
-       $(CP) $(PKG_BUILD_DIR)/tools/kwboot \
-               $(BIN_DIR)/u-boot-kwboot/
+       $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-u-boot-spl.kwb
 endef
 
 endef
 
-define Package/uboot/install/template
-define Package/uboot-mvebu-$(1)/install
-       $(call Package/uboot/install/default,$(2))
-endef
-endef
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call BuildUBootPackage,$(u))) \
-       $(eval $(call BuildPackage,uboot-mvebu-$(u))) \
-)
+$(eval $(call BuildPackage/U-Boot))
diff --git a/package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch b/package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch
deleted file mode 100644 (file)
index 7e46084..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -348,7 +348,7 @@ OBJDUMP            = $(CROSS_COMPILE)objdump
- AWK           = awk
- PERL          = perl
- PYTHON                = python
--DTC           = dtc
-+DTC           = $(DTC_DIR)dtc
- CHECK         = sparse
- CHECKFLAGS     := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
index d4596c5935fd4c9e4343f6ff027e1ad84066afcf..96df359a613d5484cf594f3f0316b73ab2811c54 100644 (file)
@@ -39,7 +39,7 @@ endef
 define Build/sdcard-img
        ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
        ./gen_mvebu_sdcard_img.sh $@ \
 define Build/sdcard-img
        ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
        ./gen_mvebu_sdcard_img.sh $@ \
-               "$(KDIR)/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
+               "$(KDIR)/clearfog-u-boot-spl.kwb" \
                c 32768 $@.boot \
                83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
 endef
                c 32768 $@.boot \
                83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
 endef
index 417007facfa00202e939f2eb9544fab880b64c72..114f758c76e52a1bbd49aa187e4dc18409383b21 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Default
        NAME:=Default Profile (all drivers)
 
 define Profile/Default
        NAME:=Default Profile (all drivers)
-       PACKAGES:= kmod-mwlwifi wpad-mini swconfig uboot-mvebu-clearfog mkf2fs e2fsprogs
+       PACKAGES:= kmod-mwlwifi wpad-mini swconfig mkf2fs e2fsprogs
 endef
 
 define Profile/Default/Description
 endef
 
 define Profile/Default/Description