bridge (brctl) changes: - enable brctl in busybox - disable bridge-utils - bumb busyb...
authorNicolas Thill <nico@openwrt.org>
Tue, 11 Nov 2008 03:02:26 +0000 (03:02 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 11 Nov 2008 03:02:26 +0000 (03:02 +0000)
SVN-Revision: 13180

include/target.mk
package/busybox/Makefile
package/busybox/config/networking/Config.in

index f3826b186548b005c75dc03566c4fbb8d93c050a..9ac5c8e96b9b5cf9609d7bfa844c314911a8fa3f 100644 (file)
@@ -14,7 +14,7 @@ DEVICE_TYPE?=router
 # Default packages - the really basic set
 DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd uci opkg
 # For router targets
 # Default packages - the really basic set
 DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd uci opkg
 # For router targets
-DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper bridge firewall
+DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
 # LuCI
 DEFAULT_PACKAGES.router+=luci-admin-full luci-admin-mini luci-i18n-english luci-app-firewall luci-sgi-cgi
 
 # LuCI
 DEFAULT_PACKAGES.router+=luci-admin-full luci-admin-mini luci-i18n-english luci-app-firewall luci-sgi-cgi
 
index 2f977942618c93b10c18a47c2945a6a9fa7e701b..3ac28987308c8eab7c8b652b7b1a89773b67283b 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.11.3
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.11.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
index 3da608d9b4a83c7a286c888c57cea56047feb256..e81a2efcef4fb949a881b6d9bc518e6caf9a4378 100644 (file)
@@ -49,14 +49,14 @@ config BUSYBOX_CONFIG_ARPING
 
 config BUSYBOX_CONFIG_BRCTL
        bool "brctl"
 
 config BUSYBOX_CONFIG_BRCTL
        bool "brctl"
-       default n
+       default y
        help
          Manage ethernet bridges.
          Supports addbr/delbr and addif/delif.
 
 config BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
        bool "Fancy options"
        help
          Manage ethernet bridges.
          Supports addbr/delbr and addif/delif.
 
 config BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
        bool "Fancy options"
-       default n
+       default y
        depends on BUSYBOX_CONFIG_BRCTL
        help
          Add support for extended option like:
        depends on BUSYBOX_CONFIG_BRCTL
        help
          Add support for extended option like:
@@ -67,7 +67,7 @@ config BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
 
 config BUSYBOX_CONFIG_FEATURE_BRCTL_SHOW
        bool "Support show, showmac and showstp"
 
 config BUSYBOX_CONFIG_FEATURE_BRCTL_SHOW
        bool "Support show, showmac and showstp"
-       default n
+       default y
        depends on BUSYBOX_CONFIG_BRCTL && BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
        help
          Add support for option which prints the current config:
        depends on BUSYBOX_CONFIG_BRCTL && BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
        help
          Add support for option which prints the current config: