bcm53xx: use otrx for creating TRX images
authorRafał Miłecki <rafal@milecki.pl>
Fri, 17 Nov 2017 10:43:33 +0000 (11:43 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 17 Nov 2017 10:43:33 +0000 (11:43 +0100)
The advantage is that we don't have to specify max TRX size anymore and
otrx doesn't allocate a buffer of that size. It saves us allocating
32 MiB for every image we generate.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/image/Makefile

index e4dca0c4e95a6c937582eb5089a5d4e3e17a24a8..596cb5ddb271cfa0b4a67dd2bdf41023e79b1ec8 100644 (file)
@@ -59,9 +59,7 @@ define Build/trx
 endef
 
 define Build/trx-serial
-       $(STAGING_DIR_HOST)/bin/trx \
-               -o $@.new \
-               -m 33554432 \
+       $(STAGING_DIR_HOST)/bin/otrx create $@.new \
                -f $(IMAGE_KERNEL) -a 1024 \
                -f $@ -a 0x10000 -A $(KDIR)/fs_mark
        mv $@.new $@
@@ -72,9 +70,7 @@ define Build/trx-nand
        #         if it grows up between releases
        # root: UBI with one extra block containing UBI mark to trigger erasing
        #       rest of partition
-       $(STAGING_DIR_HOST)/bin/trx \
-               -o $@.new \
-               -m 33554432 \
+       $(STAGING_DIR_HOST)/bin/otrx create $@.new \
                -f $(IMAGE_KERNEL) -a 0x20000 -b 0x400000 \
                -f $@ \
                -A $(KDIR)/ubi_mark -a 0x20000