include .targetinfo in the image builder, and allow direct calls to the package_index...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jan 2007 10:49:00 +0000 (10:49 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jan 2007 10:49:00 +0000 (10:49 +0000)
SVN-Revision: 6093

target/imagebuilder/Makefile
target/imagebuilder/files/Makefile

index f09bdbd2c2805936d090e4e0c1812be6549022e0..439a103428472f0817befd1c67321f286336f2f1 100644 (file)
@@ -25,6 +25,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: FORCE
                $(INCLUDE_DIR) $(SCRIPT_DIR) $(PACKAGE_DIR) \
                $(TOPDIR)/rules.mk $(TOPDIR)/.config \
                $(TMP_DIR)/.target.mk \
+               $(TMP_DIR)/.targetinfo \
                ./files/Makefile \
                $(IB_BUILD_DIR)/
        $(CP) $(STAGING_DIR)/bin/* $(IB_BUILD_DIR)/staging_dir_$(ARCH)/bin
index 720bcfa768777148278ef52ed1954c0286b3f635..d4bcdf5fa93aa67f6112762adceba33ab2531aff 100644 (file)
@@ -88,7 +88,7 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
 BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
 BUILD_PACKAGES:=$(patsubst base-files,base-files-$(BOARD)-$(KERNEL),$(BUILD_PACKAGES))
 
-image: $(TOPDIR)/tmp/ipkg.conf
+image:
        if [ -z "$($(PROFILE)_NAME)" ]; then \
                echo Profile $(PROFILE) not found.; \
                echo 'Use "make info" to get a list of available target profiles'; \
@@ -107,7 +107,7 @@ endif
        $(MAKE) package_postinst
        $(MAKE) build_image
        
-package_index: FORCE
+package_index: $(TOPDIR)/tmp/ipkg.conf FORCE
        @echo
        @echo Building package index...
        (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages) >/dev/null 2>/dev/null