remove DIST and add EXTRAVERSION, discussed with mbm. fixed dirclean target for links...
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 21 Feb 2005 06:03:54 +0000 (06:03 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 21 Feb 2005 06:03:54 +0000 (06:03 +0000)
SVN-Revision: 279

openwrt/Makefile
openwrt/package/config/mconf.c
openwrt/package/openwrt/openwrt.mk
openwrt/target/Makefile.in

index 43ee3ddba5012fc1a618c90b72ee1cbf093716b6..172e1b80c2d834481f9c620424431969de60f924 100644 (file)
@@ -128,11 +128,11 @@ source: $(TARGETS_SOURCE)
 #############################################################
 clean: 
        rm -rf $(TARGET_DIR) $(IMAGE).*
-       $(MAKE) $(DIST)-image-clean
+       $(MAKE) openwrt-image-clean
 
 dirclean: $(TARGETS_DIRCLEAN)
        rm -rf $(TARGET_DIR) $(IMAGE).*
-       $(MAKE) $(DIST)-image-clean
+       $(MAKE) openwrt-image-dirclean
 
 distclean: clean
        rm -rf $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR) 
index 0db6f8f6c8a8d1d76e660194b0f924d1b82eeb22..659e49cd64183ecbda497e7e546c668a233daf87 100644 (file)
@@ -705,6 +705,7 @@ int main(int ac, char **av)
                conf_write(NULL);
                printf("\n\n"
                        "*** End of Buildroot configuration.\n"
+                       "*** After changing root fs, use make linux-dirclean.\n"
                        "*** Check the top-level Makefile for additional configuration options.\n\n");
        } else
                printf("\n\nYour Buildroot configuration changes were NOT saved.\n\n");
index dcd18560ba59f6aad59555affaca2e963f4167df..5c3f6b105921b5a6c2532a45f395c7e4694cf7ca 100644 (file)
@@ -62,7 +62,7 @@ linksys-nvram-clean:
        -$(MAKE) -C $(LINKSYS_NVRAM_BUILD_DIR) clean
 
 linksys-nvram-dirclean:
-       rm -rf $(LINKSYS_NVRAM_BUILD_DIR)
+       rm -rf $(LINKSYS_NVRAM_DIR)
 
 # wlconf tool extracted from linksys firmware GPL sourcetree
 # WRT54GS_3_37_2_1109_US
@@ -94,7 +94,7 @@ linksys-wlconf-clean:
        -$(MAKE) -C $(LINKSYS_WLCONF_BUILD_DIR) clean
 
 linksys-wlconf-dirclean:
-       rm -rf $(LINKSYS_WLCONF_BUILD_DIR)
+       rm -rf $(LINKSYS_WLCONF_DIR)
 
 # mtd tool
 OPENWRT_MTD_SOURCE=package/openwrt/mtd.c
@@ -144,5 +144,9 @@ openwrt-addpattern: $(OPENWRT_ADDPATTERN_TARGET)
 openwrt-addpattern-clean: 
        rm $(OPENWRT_ADDPATTERN_TARGET)
 
-openwrt:       linksys-shared linksys-nvram linksys-wlconf openwrt-mtd openwrt-trx openwrt-addpattern
+linksys:       linksys-shared linksys-nvram linksys-wlconf
+
+openwrt:       linksys openwrt-mtd openwrt-trx openwrt-addpattern openwrt-jffs2root
+
+openwrt-dirclean: linksys-shared-dirclean linksys-nvram-dirclean linksys-wlconf-dirclean
 
index 7a212e489f82ba07840acb603df7b84a53fa7901..15cf6bdedeee7eea1f4952c8be20524e235b4855 100644 (file)
@@ -1,5 +1,5 @@
 # Default target skeleton stuff, may be overridden
-DIST=openwrt
+EXTRAVERSION=
 TARGET_SKELETON=target/default/skel.tar.gz
 TARGET_SKEL_DIR=target/default/target_skeleton
 
@@ -10,16 +10,20 @@ JFFS2FLAGS+=-a 131072
 endif
 
 
-$(DIST)-linux.trx: openwrt-trx
-       PATH=$(TARGET_PATH) trx -o $(DIST)-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(JFFS2FLAGS) $(IMAGE).$(ROOTFS)
+openwrt-linux.trx: openwrt-trx
+       PATH=$(TARGET_PATH) trx -o openwrt-linux$(EXTRAVERSION).trx \
+        $(LINUX_DIR)/$(LINUX_BINLOC) $(JFFS2FLAGS) $(IMAGE).$(ROOTFS)
 
-$(DIST)-gs-code.bin: openwrt-addpattern $(DIST)-linux.trx
-       PATH=$(TARGET_PATH) addpattern -2 -i  $(DIST)-linux.trx -o $(DIST)-gs-code.bin -g
+openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+       PATH=$(TARGET_PATH) addpattern -2 -i  openwrt-linux$(EXTRAVERSION).trx \
+       -o openwrt-gs-code$(EXTRAVERSION).bin -g
 
-$(DIST)-g-code.bin: $(DIST)-gs-code.bin
-       sed -e "1s,^W54S,W54G," < $(DIST)-gs-code.bin > $(DIST)-g-code.bin
+openwrt-g-code.bin: openwrt-gs-code.bin
+       sed -e "1s,^W54S,W54G," < openwrt-gs-code$(EXTRAVERSION).bin > openwrt-g-code$(EXTRAVERSION).bin
 
-openwrt-image: openwrt $(DIST)-g-code.bin
+openwrt-image: openwrt openwrt-g-code.bin
 
-$(DIST)-image-clean:
-       @-rm $(DIST)-* 2>/dev/null
+openwrt-image-clean: 
+       @-rm openwrt-* 2>/dev/null
+
+openwrt-image-dirclean: openwrt-dirclean