hostapd: remove #ifdef MULTICALL around ap+sta support code (to support separately...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 12 Nov 2013 22:11:14 +0000 (22:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 12 Nov 2013 22:11:14 +0000 (22:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 38782

package/network/services/hostapd/patches/453-ap_sta_support.patch
package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch
package/network/services/hostapd/patches/500-random_pool_add_kernel.patch
package/network/services/hostapd/patches/601-wpa_supplicant-add-new-config-params-to-be-used-with.patch
package/network/services/hostapd/patches/604-wpa_s-support-htmode-param.patch

index 80acbd34be5f400e23f69da1ce259166ad951298..d4b6c1da04dfab4d7745e26ba8987f086734bc75 100644 (file)
  -include .config
  -include $(if $(MULTICALL),../hostapd/.config)
  
-@@ -76,6 +80,10 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
+@@ -76,6 +80,8 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
  OBJS_c += ../src/utils/wpa_debug.o
  OBJS_c += ../src/utils/common.o
  
-+ifdef MULTICALL
 +OBJS += ../src/common/wpa_ctrl.o
-+endif
 +
  ifndef CONFIG_OS
  ifdef CONFIG_NATIVE_WINDOWS
  CONFIG_OS=win32
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -109,6 +109,48 @@ extern int wpa_debug_show_keys;
+@@ -109,6 +109,46 @@ extern int wpa_debug_show_keys;
  extern int wpa_debug_timestamp;
  extern struct wpa_driver_ops *wpa_drivers[];
  
-+#ifdef MULTICALL
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
 +      const char *cmd = "DOWN";
 +      }
 +      return 0;
 +}
-+#endif
 +
  /* Configure default/group WEP keys for static WEP */
  int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
  {
-@@ -676,8 +718,16 @@ void wpa_supplicant_set_state(struct wpa
+@@ -676,8 +716,12 @@ void wpa_supplicant_set_state(struct wpa
  #endif /* CONFIG_P2P */
  
                sme_sched_obss_scan(wpa_s, 1);
-+#ifdef MULTICALL
 +              if (wpa_s->hostapd)
 +                      hostapd_reload(wpa_s, wpa_s->current_bss);
-+#endif
        } else if (state == WPA_DISCONNECTED || state == WPA_ASSOCIATING ||
                   state == WPA_ASSOCIATED) {
-+#ifdef MULTICALL
 +              if (wpa_s->hostapd)
 +                      hostapd_stop(wpa_s);
-+#endif
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -2874,6 +2924,21 @@ static int wpa_supplicant_init_iface(str
-               os_strlcpy(wpa_s->bridge_ifname, iface->bridge_ifname,
+@@ -2875,6 +2919,20 @@ static int wpa_supplicant_init_iface(str
                           sizeof(wpa_s->bridge_ifname));
        }
-+#ifdef MULTICALL
 +      if (iface->hostapd_ctrl) {
 +              char *cmd = "DOWN";
 +              char buf[256];
 +              if (hostapd_stop(wpa_s) < 0)
 +                      return -1;
 +      }
-+#endif
++
        /* RSNA Supplicant Key Management - INITIALIZE */
        eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
+       eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
 --- a/wpa_supplicant/bss.c
 +++ b/wpa_supplicant/bss.c
 @@ -11,6 +11,7 @@
index e8d8910a41031fffbf9239015077254b431a358b..8dc0a5de0752ee693dda1b269467130e8a07fc55 100644 (file)
@@ -43,7 +43,7 @@
                        reply_len = -1;
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -770,6 +770,9 @@ ifdef CONFIG_WNM
+@@ -768,6 +768,9 @@ ifdef CONFIG_WNM
  OBJS += ../src/ap/wnm_ap.o
  endif
  ifdef CONFIG_CTRL_IFACE
index b6ef397b2904c903f6a19e3499c4fe06c92987e8..b47143d00f79ef4b00737a9f5488cb4c59e806af 100644 (file)
 +}
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -1238,9 +1238,8 @@ endif
+@@ -1236,9 +1236,8 @@ endif
  
  ifdef CONFIG_NO_RANDOM_POOL
  CFLAGS += -DCONFIG_NO_RANDOM_POOL
index eb0c4c259202d4fe1650ca96184f590651bd60aa..0e3f248fcf73c7e45337edcfb38844662f8acc09 100644 (file)
@@ -175,7 +175,7 @@ Signed-hostap: Antonio Quartulli <ordex@autistici.org>
  #endif /* CONFIG_SSID_H */
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -1600,15 +1600,24 @@ void wpa_supplicant_associate(struct wpa
+@@ -1594,15 +1594,24 @@ void wpa_supplicant_associate(struct wpa
                params.ssid_len = ssid->ssid_len;
        }
  
index 770f22a5f00ebc799285efc39f238b92ff03fe06..7b980926d5c3a9def95f76cc20ba2e9360bb7929 100644 (file)
@@ -145,7 +145,7 @@ Signed-off-by: Antonio Quartulli <ordex@autistici.org>
  #endif /* CONFIG_SSID_H */
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -1616,6 +1616,8 @@ void wpa_supplicant_associate(struct wpa
+@@ -1610,6 +1610,8 @@ void wpa_supplicant_associate(struct wpa
                        i++;
                }
                params.mcast_rate = ssid->mcast_rate;