ath79: fix support for TL-MR3020 v1
authorChuanhong Guo <gch981213@gmail.com>
Thu, 2 Aug 2018 07:14:10 +0000 (15:14 +0800)
committerMathias Kresin <dev@kresin.me>
Mon, 6 Aug 2018 05:31:54 +0000 (07:31 +0200)
Change lan and it's LED to eth0
It's broken since c7c807cb8c3fd6538101de885f66d4681785defe
where I changed the dts but forgot to change default configurations.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network

index 5cb8e13..4443a55 100755 (executable)
@@ -46,7 +46,7 @@ case "$board" in
        ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
        ;;
 "tplink,tl-mr3020-v1")
-       ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x02"
+       ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
        ;;
 "tplink,tl-wr1043nd-v4")
        ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x20"
index b7c2213..2cffbee 100755 (executable)
@@ -17,6 +17,7 @@ ath79_setup_interfaces()
        "pcs,cap324"|\
        "tplink,re450-v2"|\
        "tplink,tl-mr10u"|\
+       "tplink,tl-mr3020-v1"|\
        "tplink,tl-wr703n"|\
        "ubnt,unifiac-lite"|\
        "ubnt,unifiac-mesh"|\
@@ -59,11 +60,6 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
                ;;
-
-       "tplink,tl-mr3020-v1")
-               ucidef_set_interface_lan "eth0.1"
-               ucidef_add_switch "switch0" "0@eth0" "1:lan"
-               ;;
        "tplink,tl-mr3220-v1"|\
        "tplink,tl-mr3420-v1"|\
        "tplink,tl-wr841-v7")