add support for the PCEngines Alix
authorTravis Kemen <thepeople@openwrt.org>
Wed, 28 Nov 2007 04:07:24 +0000 (04:07 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Wed, 28 Nov 2007 04:07:24 +0000 (04:07 +0000)
SVN-Revision: 9611

target/linux/x86/config-2.6.23
target/linux/x86/generic/profiles/Alix.mk [new file with mode: 0644]

index d04514b1614d6d002ea366cea7363f2d45ce37e3..c12a2f95cffb246f8177afcd65ddc4903cdc3a67 100644 (file)
@@ -349,7 +349,7 @@ CONFIG_USB_UHCI_HCD=m
 # CONFIG_VGASTATE is not set
 CONFIG_VGA_CONSOLE=y
 CONFIG_VIA_RHINE=m
-# CONFIG_VIA_RHINE_MMIO is not set
+CONFIG_VIA_RHINE_MMIO=y
 CONFIG_VIA_RHINE_NAPI=y
 # CONFIG_VIDEO_SELECT is not set
 # CONFIG_VIRTUALIZATION is not set
diff --git a/target/linux/x86/generic/profiles/Alix.mk b/target/linux/x86/generic/profiles/Alix.mk
new file mode 100644 (file)
index 0000000..24f5bf1
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Alix
+  NAME:=PCEngines Alix
+  PACKAGES:=kmod-via-rhine
+endef
+
+define Profile/Alix/Description
+        Package set compatible with the PCEngines Alix. Contains VIA Rhine III VT6105M support
+endef
+$(eval $(call Profile,Alix))