sunxi: Add support for Banana Pi M2 Ultra
authorHal Martin <hal.martin@gmail.com>
Sat, 7 Sep 2019 16:28:18 +0000 (16:28 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 20 Sep 2019 23:12:35 +0000 (01:12 +0200)
CPU: Allwinner R40 Quad-Core Cortex-A7 @ 1.2GHz
GPU: Mali 400 MP2
Memory: 2GB DDR3 onboard (shared with GPU)
Onboard: Storage microSD card slot
Onboard: Storage 8GB eMMC
Onboard: Network 10/100/1000M Ethernet RJ45
Onboard: Network WiFi 802.11b/g/n 1x1 (AMPAK AP6212; brcmfmac)
Onboard header: SPI, I2C, GPIO, UART
USB: Two USB 2.0 Host, One USB 2.0 OTG

Known issues:
- WiFi doesn't work
- eMMC not supported

Signed-off-by: Hal Martin <hal.martin@gmail.com>
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/250-Sinovoip-BPI-M2-Ultra-defconfig.patch [new file with mode: 0644]
target/linux/sunxi/Makefile
target/linux/sunxi/cortexa7/target.mk
target/linux/sunxi/image/cortex-a7.mk

index 6b83bd27c65633fed63c379cd33ddfc2c980c05c..2c414f8c9e0a472be3f665fe22f7431fa94922de 100644 (file)
@@ -247,6 +247,12 @@ define U-Boot/orangepi_pc2
   UENV:=a64
 endef
 
+define U-Boot/Sinovoip_BPI_M2_Ultra
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Bananapi M2 Ultra
+  BUILD_DEVICES:=sun8i-r40-bananapi-m2-ultra
+endef
+
 UBOOT_TARGETS := \
        A10-OLinuXino-Lime \
        A13-OLinuXino \
@@ -281,6 +287,7 @@ UBOOT_TARGETS := \
        pangolin \
        pine64_plus \
        Sinovoip_BPI_M2_Plus \
+       Sinovoip_BPI_M2_Ultra \
        sopine_baseboard \
        orangepi_zero_plus
 
diff --git a/package/boot/uboot-sunxi/patches/250-Sinovoip-BPI-M2-Ultra-defconfig.patch b/package/boot/uboot-sunxi/patches/250-Sinovoip-BPI-M2-Ultra-defconfig.patch
new file mode 100644 (file)
index 0000000..94606aa
--- /dev/null
@@ -0,0 +1,25 @@
+--- /dev/null
++++ b/configs/Sinovoip_BPI_M2_Ultra_defconfig
+@@ -0,0 +1,22 @@
++CONFIG_ARM=y
++CONFIG_ARCH_SUNXI=y
++CONFIG_SPL=y
++CONFIG_MACH_SUN8I_R40=y
++CONFIG_DRAM_CLK=576
++CONFIG_DRAM_ZQ=3881979
++CONFIG_MACPWR="PA17"
++CONFIG_MMC0_CD_PIN="PH13"
++CONFIG_MMC_SUNXI_SLOT_EXTRA=2
++CONFIG_AHCI=y
++CONFIG_NR_DRAM_BANKS=1
++# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
++CONFIG_SPL_I2C_SUPPORT=y
++# CONFIG_CMD_FLASH is not set
++CONFIG_DEFAULT_DEVICE_TREE="sun8i-r40-bananapi-m2-ultra"
++CONFIG_SCSI_AHCI=y
++CONFIG_RGMII=y
++CONFIG_SUN8I_EMAC=y
++CONFIG_AXP_DLDO4_VOLT=2500
++CONFIG_AXP_ELDO3_VOLT=1200
++CONFIG_SCSI=y
++CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y
index cd1bf30e84f902589cc46c2773dfd59b447e3d0e..e1630fb44127d67b89cc57fb52d6163ebf662168 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=sunxi
-BOARDNAME:=Allwinner A1x/A20/A3x
+BOARDNAME:=Allwinner A1x/A20/A3x/R40
 FEATURES:=fpu usb ext4 display rtc squashfs
 SUBTARGETS:=cortexa8 cortexa7 cortexa53
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
@@ -23,6 +23,7 @@ KERNELNAME:=zImage dtbs
 # A31: quad Cortex-A7
 # A80: octa Cortex-A15/A7
 # H3: quad Cortex-A7
+# R40: quad Cortex-A7
 
 include $(INCLUDE_DIR)/target.mk
 
index 16aa9f7d0a1fe52a5b2c720cb993e6bf83d423ce..b6bdd483bb8a87f8002cb6ee512a660cd4bdf6ca 100644 (file)
@@ -7,6 +7,6 @@
 
 include $(TOPDIR)/rules.mk
 
-BOARDNAME:=Allwinner A20/A3x
+BOARDNAME:=Allwinner A20/A3x/R40
 CPU_TYPE:=cortex-a7
 CPU_SUBTYPE:=neon-vfpv4
index 05c4328d8e431eea33594604b45a254f98b7a442..3375a4542c1a8969314a14dc08ba2c1d67b6d2b6 100644 (file)
@@ -239,4 +239,14 @@ endef
 
 TARGET_DEVICES += sun7i-a20-pcduino3
 
+define Device/sun8i-r40-bananapi-m2-ultra
+  DEVICE_VENDOR := LeMaker
+  DEVICE_MODEL := Banana Pi M2 Ultra
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
+  SUPPORTED_DEVICES:=lemaker,bananapi-m2-ultra
+  SUNXI_DTS:=sun8i-r40-bananapi-m2-ultra
+endef
+
+TARGET_DEVICES += sun8i-r40-bananapi-m2-ultra
+
 endif