remove unneeded config options, too
authorImre Kaloz <kaloz@openwrt.org>
Fri, 29 Oct 2010 10:55:54 +0000 (10:55 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 29 Oct 2010 10:55:54 +0000 (10:55 +0000)
SVN-Revision: 23706

toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 943b625..08c69de 100644 (file)
@@ -19,33 +19,12 @@ choice
        config GCC_VERSION_4_2_4
                bool "gcc 4.2.4"
 
-       config GCC_VERSION_4_3_3
-               bool "gcc 4.3.3"
-
-       config GCC_VERSION_4_3_4
-               bool "gcc 4.3.4"
-
        config GCC_VERSION_4_3_5
                bool "gcc 4.3.5"
 
-       config GCC_VERSION_4_4_1
-               bool "gcc 4.4.1"
-
-       config GCC_VERSION_4_4_2
-               bool "gcc 4.4.2"
-
-       config GCC_VERSION_4_4_3
-               bool "gcc 4.4.3"
-
-       config GCC_VERSION_4_4_4
-               bool "gcc 4.4.4"
-
        config GCC_VERSION_4_4_5
                bool "gcc 4.4.5"
 
-       config GCC_VERSION_4_5_0
-               bool "gcc 4.5.0"
-
        config GCC_VERSION_4_5_1
                bool "gcc 4.5.1"
 
@@ -62,10 +41,6 @@ choice
        config GCC_VERSION_4_4_1_CS
                bool "gcc 4.4.1 with CodeSourcery enhancements"
 
-       config GCC_VERSION_4_4_3_CS
-               bool "gcc 4.4.3 with CodeSourcery enhancements"
-               depends BROKEN
-
 endchoice
 
 config GCC_USE_GRAPHITE
index ecae8df..731e247 100644 (file)
@@ -2,20 +2,12 @@ config GCC_VERSION
        string
        default "4.1.2"     if GCC_VERSION_4_1_2
        default "4.2.4"     if GCC_VERSION_4_2_4
-       default "4.3.3"     if GCC_VERSION_4_3_3
        default "4.3.3+cs"  if GCC_VERSION_4_3_3_CS
-       default "4.3.4"     if GCC_VERSION_4_3_4
        default "4.3.5"     if GCC_VERSION_4_3_5
-       default "4.4.1"     if GCC_VERSION_4_4_1
        default "4.4.1+cs"  if GCC_VERSION_4_4_1_CS
-       default "4.4.2"     if GCC_VERSION_4_4_2
-       default "4.4.3"     if GCC_VERSION_4_4_3
-       default "4.4.4"     if GCC_VERSION_4_4_4
        default "4.4.5"     if GCC_VERSION_4_4_5
-       default "4.5.0"     if GCC_VERSION_4_5_0
        default "4.5.1"     if GCC_VERSION_4_5_1
        default "4.5.1+l"   if GCC_VERSION_4_5_1_LINARO
-       default "4.4.3+cs"  if GCC_VERSION_4_4_3_CS
        default "llvm"      if GCC_VERSION_LLVM
        default "4.1.2"
 
@@ -38,24 +30,16 @@ config GCC_VERSION_4_2
 
 config GCC_VERSION_4_3
        bool
-       default y       if GCC_VERSION_4_3_3
        default y       if GCC_VERSION_4_3_3_CS
-       default y       if GCC_VERSION_4_3_4
        default y       if GCC_VERSION_4_3_5
 
 config GCC_VERSION_4_4
        bool
-       default y       if GCC_VERSION_4_4_1
        default y       if GCC_VERSION_4_4_1_CS
-       default y       if GCC_VERSION_4_4_2
-       default y       if GCC_VERSION_4_4_3
-       default y       if GCC_VERSION_4_4_3_CS
-       default y       if GCC_VERSION_4_4_4
        default y       if GCC_VERSION_4_4_5
 
 config GCC_VERSION_4_5
        bool
-       default y       if GCC_VERSION_4_5_0
        default y       if GCC_VERSION_4_5_1
        default y       if GCC_VERSION_4_5_1_LINARO