upgrade & standardize kernel versions
authorImre Kaloz <kaloz@openwrt.org>
Mon, 11 Feb 2008 10:50:40 +0000 (10:50 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 11 Feb 2008 10:50:40 +0000 (10:50 +0000)
SVN-Revision: 10443

23 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/amazon/Makefile
target/linux/ar7/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/olpc/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ps3/Makefile
target/linux/pxa/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index 5ecd305ac0b54fe8dd004a9b5aa60695e2973ce8..b3aaf00868d7d6507e0cde5510addc403b27a011 100644 (file)
@@ -13,23 +13,17 @@ endif
 ifeq ($(LINUX_VERSION),2.4.35.4)
   LINUX_KERNEL_MD5SUM:=34066faff3d8c042df1c7600b08b8070
 endif
-ifeq ($(LINUX_VERSION),2.6.22.4)
-  LINUX_KERNEL_MD5SUM:=6cf83acf21e65dcea4a5170c0bbc7125
+ifeq ($(LINUX_VERSION),2.6.21.7)
+  LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
 endif
-ifeq ($(LINUX_VERSION),2.6.21.5)
-  LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
+ifeq ($(LINUX_VERSION),2.6.22.18)
+  LINUX_KERNEL_MD5SUM:=bd375d5885bf114c74a2216d52d86e34
 endif
-ifeq ($(LINUX_VERSION),2.6.23)
-  LINUX_KERNEL_MD5SUM:=2cc2fd4d521dc5d7cfce0d8a9d1b3472
+ifeq ($(LINUX_VERSION),2.6.23.16)
+  LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
 endif
-ifeq ($(LINUX_VERSION),2.6.23.1)
-  LINUX_KERNEL_MD5SUM:=518d57e08fdacd88907166a3bfe383b7
-endif
-ifeq ($(LINUX_VERSION),2.6.23.14)
-  LINUX_KERNEL_MD5SUM:=63a6a28ad2480edcffbc09c008b0939d
-endif
-ifeq ($(LINUX_VERSION),2.6.24)
-  LINUX_KERNEL_MD5SUM:=3f23ad4b69d0a552042d1ed0f4399857
+ifeq ($(LINUX_VERSION),2.6.24.2)
+  LINUX_KERNEL_MD5SUM:=dd573a2fae55624ed92fa49c17583964
 endif
 
 # disable the md5sum check for unknown kernel versions
index c7c66705a3d6dc8858729d653c2080e79d2283eb..a397f2a26f7ddec260b0a690cd4f3e794cfdcfd0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index b8491c2fd2cb151ebac9942c1533476af62ac175..576f8508b94f4f0519236d6efa2ab151da58de77 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
 
 include $(INCLUDE_DIR)/target.mk
 
index abe32eb3e8168cb434bb71ed9c3f3b016cf26398..fc83f9a0501086ae955b488c021fed07d8b5361d 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index dfa3bfbb65417605c60e9ca3958c0ffe36493fe4..fb04344e2922e6aae611abb355a2d9d7951a4dca 100644 (file)
@@ -11,8 +11,7 @@ BOARD:=at91
 BOARDNAME:=AT91
 FEATURES:=squashfs usb
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.22.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 93f026b214dfaed525103465ad1d5328fbcd2f7b..6cab959b0d7e1752b2506d56deeada840ae8aceb 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.23.1
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 77b8c96f955c1e76d5b3de0c5ed87eb67dd303b8..4b492845bc9869df9b1883d812401229204cfa3b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 36f7ef7779847d5e338be531893c2150ee71ec47..50b60f169980a33e6dcebb9082af417a693d183e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.23.1
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
index 0e0898461763cc92ad9f34911c89bfcb0552f3e3..c465c867c102920b0a5d5809a0e41f07737e07c2 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.22.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 1818e6b8e91ac182225c5f9c6ed217031b11b670..e63ad086cdaaa375657508d65501e7953b7f908f 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.23
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 8267625c9786320a1e838ab0a8ae2160921d1558..ccecf204c8f3e4aac29150ce4f5299b053d816be 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel XScale IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 5ef4c8ce2031d58c98112ade063a15dcb20f6189..ec931a0a991a02833262b34534ff75776943ea95 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel XScale IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index fae0ebf757577aa052ce76af5eabf6a25676ddd4..c03093e00e316608de789600d5a5744c557fef67 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index 4ab33753739ed52b345e6be55eb5ced485179614..8bf4cd804a6674ccec3e947d74239fc122d0ea1e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=olpc
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.23
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
index cd64ea3f65d330a64c30665652f49481aacf80b8..b081849db803dc646fa6b425f6e6518e4ec6dd4e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC Kilauea
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 9b4342c3d01926b0bf68d89e3f1f94c38293af94..7e7061265b0a90741cff8613e00a5436eb90f12e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC Taishan
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 3499d024bd39bbb49f3a28511848591feb722d5f..653ba80def5072d22080fe3a4a16148e063056f0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PlayStation 3
-LINUX_VERSION:=2.6.23
+LINUX_VERSION:=2.6.23.16
 KERNEL_CC:=
 
 include $(INCLUDE_DIR)/target.mk
index b5985ea74d1dad1d782be7262bc6bd64b7a749ef..7bf4c38f1cd3524e2c25dce72919c754b007dd26 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=pxa
 BOARDNAME:=PXA
 FEATURES:=jffs2 broken
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 69e9eab40c0efc2c0cc18832e8ba8cc0fdd473db..9e4fcca5ef3556c144a0d80146a9b72704065797 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a61ae3f4f7b9b04265ba4870bbea8d4d3de54b0..1b70c1876fca54aa54d48ca9241f289c332fce55 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rdc
 BOARDNAME:=RDC321x x86
 FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 74c15cb328e507de3c7ac097c0de2bb4052fed74..dfc863222d1ba7edd6545665216111186898b160 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 11c8b76468da4898c3d7155df88c77014e86f541..ebcfbbc99a64e539144439980b76913de23533a1 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=broken ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 6cb5c3d3fde954d7ce8478406ebf8bee5d40b1a7..afff2c6a6af5a99fc8fe88e0790028d34d9c428a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
 SUBTARGETS=generic mediacenter
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci