add support for arv7525
authorJohn Crispin <john@openwrt.org>
Tue, 6 Nov 2012 07:38:24 +0000 (07:38 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 6 Nov 2012 07:38:24 +0000 (07:38 +0000)
SVN-Revision: 34097

target/linux/lantiq/image/Makefile
target/linux/lantiq/xway/profiles/001-lantiq.mk

index de5365e676d7fe63eb9759a9229404bcbf6f7385..11374ef94545b24c80a5a47376b6d0727a1199c6 100644 (file)
@@ -207,6 +207,9 @@ Image/Build/Profile/EASY80920-NAND=$(call Image/Build/$(1),$(1),EASY80920-NAND)
 Image/BuildKernel/Profile/EASY80920-NOR=$(call Image/BuildKernel/Template,EASY80920-NOR)
 Image/Build/Profile/EASY80920-NOR=$(call Image/Build/$(1),$(1),EASY80920-NOR)
 
+Image/BuildKernel/Profile/ARV7525PW=$(call Image/BuildKernel/Template,ARV7525PW)
+Image/Build/Profile/ARV7525PW=$(call Image/Build/$(1),$(1),ARV7525PW)
+
 endif
 
 ifeq ($(CONFIG_TARGET_lantiq_vr9),y)
index 2c24d3c95ed8bff363930c513fdbd09f59fbdac2..6243568d8388ade4533bbd466ba29cd509429d6e 100644 (file)
@@ -17,3 +17,13 @@ define Profile/EASY80920-NAND/Description
 endef
 
 $(eval $(call Profile,EASY80920-NAND))
+
+define Profile/ARV7525PW
+  NAME:=ARV7525PW
+endef
+
+define Profile/ARV7525PW/Description
+       Speedport W303V - ARV7525PW
+endef
+
+$(eval $(call Profile,ARV7525PW))