gettext-full: add gmsgfmt symlink in host install
authorStijn Tintel <stijn@linux-ipv6.be>
Fri, 25 Mar 2022 13:03:53 +0000 (15:03 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 4 Apr 2022 22:20:24 +0000 (00:20 +0200)
Some configure scripts look for msgfmt and gmsgfmt. As we don't install
the latter, configure might pick up one from staging_dir/hostpkg, and
the other from the host:

checking for msgfmt... /home/stijn/Development/OpenWrt/openwrt/staging_dir/hostpkg/bin/msgfmt
checking for gmsgfmt... /usr/bin/gmsgfmt

This could potentially lead to hard to debug undefined behaviour.
Install a symlink in the host install phase to avoid this.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
(cherry picked from commit 636cb00ecc8d693c36e48952f6d154f91e0e569e)

package/libs/gettext-full/Makefile

index 6a97fd5b91201d8e4b594152d3e9e309f5751b56..f5f5e00542c25d9aa3002673e96c9ad0538f658a 100644 (file)
@@ -88,6 +88,11 @@ define Build/InstallDev
        $(SED) '/read dummy/d' $(STAGING_DIR_HOSTPKG)/bin/gettextize
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(LN) msgfmt $(STAGING_DIR_HOSTPKG)/bin/gmsgfmt
+endef
+
 define Package/libintl-full/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.so.* $(1)/usr/lib/