ar71xx: ubnt-(xm,xw): add rssileds package
authorLech Perczak <lech.perczak@gmail.com>
Sun, 17 Nov 2019 19:58:27 +0000 (20:58 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 26 Nov 2019 16:01:01 +0000 (17:01 +0100)
In order to make RSSI indicator on the device work out of box,
include "rssileds" package in per-device rootfs image by default
for Ubiquiti XM and XW devices, namely:
- Bullet M (XM/XW)
- Rocket M (XM/XW)
- Nanostation M (XM/XW)
- Nanostation Loco-M (XW)

This moves the package addition to the individual devices in order
to prevent accidental inclusions of the package when not looking
at the parent node carefully enough.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
[add bullet-m-xw, remove rocket-m-ti, extend commit message]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
(cherry picked from commit 08d9c95417399ac8615df210f4381cca68a4b25c)

target/linux/ar71xx/image/generic-ubnt.mk

index c7d17f20aaa480bd1acd43cc10e4fa40735d5f77..c155cbd817eec62fb24b4a80dd0db900f2a5ba69 100644 (file)
@@ -56,7 +56,7 @@ endef
 
 define Device/ubnt-xm
   $(Device/ubnt)
 
 define Device/ubnt-xm
   $(Device/ubnt)
-  DEVICE_PACKAGES += kmod-usb-ohci rssileds
+  DEVICE_PACKAGES += kmod-usb-ohci
   UBNT_TYPE := XM
   UBNT_CHIP := ar7240
   KERNEL := kernel-bin | patch-cmdline | relocate-kernel | lzma | uImage lzma
   UBNT_TYPE := XM
   UBNT_CHIP := ar7240
   KERNEL := kernel-bin | patch-cmdline | relocate-kernel | lzma | uImage lzma
@@ -64,7 +64,6 @@ endef
 
 define Device/ubnt-xw
   $(Device/ubnt)
 
 define Device/ubnt-xw
   $(Device/ubnt)
-  DEVICE_PACKAGES += rssileds
   UBNT_TYPE := XW
   UBNT_CHIP := ar934x
   UBNT_VERSION := 6.0.4
   UBNT_TYPE := XW
   UBNT_CHIP := ar934x
   UBNT_VERSION := 6.0.4
@@ -94,6 +93,7 @@ TARGET_DEVICES += ubnt-airrouter
 define Device/ubnt-bullet-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Bullet-M
 define Device/ubnt-bullet-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Bullet-M
+  DEVICE_PACKAGES += rssileds
   BOARDNAME := UBNT-BM
 endef
 TARGET_DEVICES += ubnt-bullet-m
   BOARDNAME := UBNT-BM
 endef
 TARGET_DEVICES += ubnt-bullet-m
@@ -101,6 +101,7 @@ TARGET_DEVICES += ubnt-bullet-m
 define Device/ubnt-rocket-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Rocket-M
 define Device/ubnt-rocket-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Rocket-M
+  DEVICE_PACKAGES += rssileds
   BOARDNAME := UBNT-RM
 endef
 TARGET_DEVICES += ubnt-rocket-m
   BOARDNAME := UBNT-RM
 endef
 TARGET_DEVICES += ubnt-rocket-m
@@ -108,6 +109,7 @@ TARGET_DEVICES += ubnt-rocket-m
 define Device/ubnt-nano-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Nano-M
 define Device/ubnt-nano-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Nano-M
+  DEVICE_PACKAGES += rssileds
   BOARDNAME := UBNT-NM
 endef
 TARGET_DEVICES += ubnt-nano-m
   BOARDNAME := UBNT-NM
 endef
 TARGET_DEVICES += ubnt-nano-m
@@ -176,6 +178,7 @@ TARGET_DEVICES += ubnt-unifi-outdoor
 define Device/ubnt-nano-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Nano M XW
 define Device/ubnt-nano-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Nano M XW
+  DEVICE_PACKAGES += rssileds
   BOARDNAME := UBNT-NM-XW
 endef
 TARGET_DEVICES += ubnt-nano-m-xw
   BOARDNAME := UBNT-NM-XW
 endef
 TARGET_DEVICES += ubnt-nano-m-xw
@@ -190,6 +193,7 @@ TARGET_DEVICES += ubnt-lbe-m5
 define Device/ubnt-loco-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Loco XW
 define Device/ubnt-loco-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Loco XW
+  DEVICE_PACKAGES += rssileds
   BOARDNAME := UBNT-LOCO-XW
 endef
 TARGET_DEVICES += ubnt-loco-m-xw
   BOARDNAME := UBNT-LOCO-XW
 endef
 TARGET_DEVICES += ubnt-loco-m-xw
@@ -197,6 +201,7 @@ TARGET_DEVICES += ubnt-loco-m-xw
 define Device/ubnt-bullet-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Bullet-M XW
 define Device/ubnt-bullet-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Bullet-M XW
+  DEVICE_PACKAGES += rssileds
   BOARDNAME := UBNT-BM-XW
 endef
 TARGET_DEVICES += ubnt-bullet-m-xw
   BOARDNAME := UBNT-BM-XW
 endef
 TARGET_DEVICES += ubnt-bullet-m-xw
@@ -204,6 +209,7 @@ TARGET_DEVICES += ubnt-bullet-m-xw
 define Device/ubnt-rocket-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Rocket M XW
 define Device/ubnt-rocket-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Rocket M XW
+  DEVICE_PACKAGES += rssileds
   BOARDNAME := UBNT-RM-XW
 endef
 TARGET_DEVICES += ubnt-rocket-m-xw
   BOARDNAME := UBNT-RM-XW
 endef
 TARGET_DEVICES += ubnt-rocket-m-xw