update bluez-utils to new upstream release (v2.24)
authorNicolas Thill <nico@openwrt.org>
Thu, 12 Jan 2006 17:14:22 +0000 (17:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 12 Jan 2006 17:14:22 +0000 (17:14 +0000)
SVN-Revision: 2938

openwrt/package/bluez-utils/Makefile

index ab08c22fb5379122fd9734e6382be2773a99fb37..00a609b55ef527434d56ab8a1c9e553ca52e2f6e 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
-PKG_VERSION:=2.17
-PKG_RELEASE:=2
-PKG_MD5SUM:=42be19b0029a83824358baa0106da947
+PKG_VERSION:=2.24
+PKG_RELEASE:=1
+PKG_MD5SUM:=
 
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,7 +18,6 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,BLUEZ_UTILS,bluez-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-
 $(PKG_BUILD_DIR)/.source: $(DL_DIR)/$(PKG_SOURCE)
        zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        touch $(BLUEZLIBS_DIR)/.source
@@ -27,37 +26,46 @@ $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
-               sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --enable-shared \
-                 --enable-static \
-                 --disable-rpath \
-                 --without-x \
-                 --with-bluez=$(STAGING_DIR)/usr/include \
-                 --with-usb=$(STAGING_DIR)/usr/include \
-                 --without-glib \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --disable-dbus \
+                       --disable-fuse \
+                       --disable-obex \
+                       --disable-alsa \
+                       --disable-cups \
+                       --disable-pcmcia \
+                       --disable-initscripts \
+                       --disable-bccmd \
+                       --disable-avctrl \
+                       --disable-hid2hci \
+                       --disable-dfutool \
+                       --disable-bcm203x \
+                       --disable-bluepin \
+                       --with-bluez=$(STAGING_DIR)/usr/include \
+                       --with-usb=$(STAGING_DIR)/usr/include \
        )
        touch $@
 
@@ -67,7 +75,6 @@ $(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
-       rm -f $(PKG_INSTALL_DIR)/usr/bin/bluepin
        touch $@
 
 $(IPKG_BLUEZ_UTILS):
@@ -79,7 +86,6 @@ $(IPKG_BLUEZ_UTILS):
        cp -fp $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
        cp -fp $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
        install -m0700 ./files/givepin $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
-
        $(RSTRIP) $(IDIR_BLUEZ_UTILS)
        $(IPKG_BUILD) $(IDIR_BLUEZ_UTILS) $(PACKAGE_DIR)