sunxi: add support for NanoPi NEO Plus2 board
authorAntony Antony <antony@phenome.org>
Thu, 28 Dec 2017 17:21:15 +0000 (18:21 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Feb 2018 00:15:24 +0000 (01:15 +0100)
arm64: allwinner: h5: NanoPi NEO Plus2 DT support
Add initial DT for NanoPi NEO Plus2 by FriendlyARM
    - Allwinner quad core H5 Cortex A53 with an ARM Mali-450MP GPU
    - 1 GB DDR3 RAM
    - 8GB eMMC flash (Samsung KLM8G1WEPD-B031)
    - micro SD card slot
    - Gigabit Ethernet (external RTL8211E-VB-CG chip)
    - 802.11 b/g/n WiFi, Bluetooth 4.0 (Ampak AP6212A module)
    - 2x USB 2.0 host ports & 2x USB via headers

Signed-off-by: Antony Antony <antony@phenome.org>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a53.mk

index 056300e1899662a463c2ceca7f2e6f925eddc453..321e7e9c034db1a5742afd5faf2d5632b037b016 100644 (file)
@@ -168,6 +168,14 @@ define U-Boot/pangolin
   UENV:=pangolin
 endef
 
+define U-Boot/nanopi_neo_plus2
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=NanoPi NEO Plus2 (H5)
+  BUILD_DEVICES:=sun50i-h5-nanopi-neo-plus2
+  DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
 define U-Boot/pine64_plus
   BUILD_SUBTARGET:=cortexa53
   NAME:=Pine64 Plus A64
@@ -197,6 +205,7 @@ UBOOT_TARGETS := \
        Lamobo_R1 \
        nanopi_m1_plus \
        nanopi_neo \
+       nanopi_neo_plus2 \
        orangepi_r1 \
        orangepi_plus \
        orangepi_2 \
index bbb253f0ae9655a0d4d07936f1e17743c2d15c45..eb31aa8d4ca680d51f26ed0836835bae493a7520 100644 (file)
@@ -7,6 +7,16 @@
 #
 ifeq ($(SUBTARGET),cortexa53)
 
+define Device/sun50i-h5-nanopi-neo-plus2
+  DEVICE_TITLE:=Nanopi NEO Plus2 (H5)
+  SUPPORTED_DEVICES:=nanopi-neo-plus2
+  SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo-plus2
+  KERNEL_NAME := Image
+  KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-nanopi-neo-plus2
+
 define Device/sun50i-a64-pine64-plus
   DEVICE_TITLE:=Pine64 Plus A64
   SUPPORTED_DEVICES:=pine64,pine64-plus