oxnas: add Default profile and reorganize device profiles
authorJohn Crispin <john@openwrt.org>
Sun, 20 Mar 2016 14:41:13 +0000 (14:41 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 20 Mar 2016 14:41:13 +0000 (14:41 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 49040

target/linux/oxnas/profiles/00-default.mk [new file with mode: 0644]
target/linux/oxnas/profiles/100-Generic.mk [deleted file]
target/linux/oxnas/profiles/mitrastar.mk [new file with mode: 0644]
target/linux/oxnas/profiles/pogoplug.mk [new file with mode: 0644]
target/linux/oxnas/profiles/shuttle.mk [new file with mode: 0644]

diff --git a/target/linux/oxnas/profiles/00-default.mk b/target/linux/oxnas/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..fb04ba7
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+       NAME:=Default Profile
+       PACKAGES:=\
+               kmod-usb-core kmod-usb3 \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/oxnas/profiles/100-Generic.mk b/target/linux/oxnas/profiles/100-Generic.mk
deleted file mode 100644 (file)
index 5304839..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/POGOPLUG_PRO
-  NAME:=PogoPlug Pro
-endef
-
-define Profile/POGOPLUG_PRO/Description
- Profile with built-in ox820 PogoPlug Pro device-tree
- (board with miniPCIe slot)
-endef
-
-define Profile/POGOPLUG_V3
-  NAME:=PogoPlug V3
-endef
-
-define Profile/POGOPLUG_V3/Description
- Profile with built-in ox820 PogoPlug V3 device-tree
- (board without miniPCIe slot)
-endef
-
-define Profile/STG212
-  NAME:=MitraStar STG-212
-endef
-
-define Profile/STG212/Description
- Profile with built-in ox820 STG-212 device-tree
-endef
-
-define Profile/KD20
-  NAME:=Shuttle KD20
-  PACKAGES:= \
-       kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
-       kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
-endef
-
-define Profile/KD20/Description
- Profile with built-in ox820 KD20 device-tree
-endef
-
-$(eval $(call Profile,POGOPLUG_PRO))
-$(eval $(call Profile,POGOPLUG_V3))
-$(eval $(call Profile,STG212))
-$(eval $(call Profile,KD20))
diff --git a/target/linux/oxnas/profiles/mitrastar.mk b/target/linux/oxnas/profiles/mitrastar.mk
new file mode 100644 (file)
index 0000000..1991c9b
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/STG212
+  NAME:=MitraStar STG-212
+endef
+
+define Profile/STG212/Description
+ Profile with built-in ox820 STG-212 device-tree
+endef
+
+$(eval $(call Profile,STG212))
diff --git a/target/linux/oxnas/profiles/pogoplug.mk b/target/linux/oxnas/profiles/pogoplug.mk
new file mode 100644 (file)
index 0000000..dcab128
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/POGOPLUG_PRO
+  NAME:=PogoPlug Pro
+endef
+
+define Profile/POGOPLUG_PRO/Description
+ Profile with built-in ox820 PogoPlug Pro device-tree
+ (board with miniPCIe slot)
+endef
+
+define Profile/POGOPLUG_V3
+  NAME:=PogoPlug V3
+endef
+
+define Profile/POGOPLUG_V3/Description
+ Profile with built-in ox820 PogoPlug V3 device-tree
+ (board without miniPCIe slot)
+endef
+
+$(eval $(call Profile,POGOPLUG_PRO))
+$(eval $(call Profile,POGOPLUG_V3))
diff --git a/target/linux/oxnas/profiles/shuttle.mk b/target/linux/oxnas/profiles/shuttle.mk
new file mode 100644 (file)
index 0000000..a83935f
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/KD20
+  NAME:=Shuttle KD20
+  PACKAGES:= \
+       kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
+       kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
+endef
+
+define Profile/KD20/Description
+ Profile with built-in ox820 KD20 device-tree
+endef
+
+$(eval $(call Profile,KD20))