if quilt failed whilst patching, no output was shown
authorJohn Crispin <john@openwrt.org>
Sun, 25 Jan 2009 17:28:11 +0000 (17:28 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 25 Jan 2009 17:28:11 +0000 (17:28 +0000)
SVN-Revision: 14178

include/quilt.mk

index c47a9262d91df5f8b272058a0d8ca46ffc15e15b..8a63442dd2ae0aa00eb09e60f69ffede68acb036 100644 (file)
@@ -126,7 +126,7 @@ define Build/Quilt
 
   $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   $(STAMP_CHECKED): $(STAMP_PATCHED)
-       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top; fi >/dev/null 2>&1); fi
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top >/dev/null 2>&1; fi); fi
        touch $$@
 
   quilt-check: $(STAMP_PREPARED) FORCE