uboot-at91: update to linux4sam-2021.10
authorClaudiu Beznea <claudiu.beznea@microchip.com>
Fri, 4 Feb 2022 13:27:51 +0000 (15:27 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 24 Feb 2022 18:05:28 +0000 (19:05 +0100)
Update uboot-at91 to linux4sam-2021.10 version.

Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
package/boot/uboot-at91/Makefile
package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
package/boot/uboot-at91/patches/010-fix_dtc_compilation_on_host_gcc10.patch [deleted file]

index ad65247e3e53096fa99124f098cf6098b62ca2d8..7052329ecd5eca1eea8ad996f5b3e3ee425df4c3 100644 (file)
@@ -7,13 +7,13 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=linux4sam-2020.04
+PKG_VERSION:=linux4sam-2021.10
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
-PKG_MIRROR_HASH:=4f106d215c01c4d024c4612bbd3ef189188d19abc1ab2cc316b257d308534feb
-PKG_SOURCE_VERSION:=0e1d1b6efb7f8e27c372279a906fcd2524df09da
+PKG_MIRROR_HASH:=f1190062f2012b182b45b78263a4cce4ada9b7b8d6f5a66d68fa51437105fc8c
+PKG_SOURCE_VERSION:=39854ce82232cdc05c20158d0439bdbc40991e4a
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
index 4c968a2448ae5ceef6d65489bc9d4b80f932c3a3..d39a91aaf04aabca736a5e1c6f9ed2c99d2ee765 100644 (file)
@@ -1,17 +1,46 @@
+From 3b05406c02070df3e7f19399d81ebd35ed6deae5 Mon Sep 17 00:00:00 2001
+From: Claudiu Beznea <claudiu.beznea@microchip.com>
+Date: Tue, 12 Oct 2021 17:43:28 +0300
+Subject: [PATCH] fix -Wformat-security
+
+Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
+---
+ cmd/panic.c                      | 2 +-
+ cmd/version.c                    | 2 +-
+ drivers/pinctrl/pinctrl-uclass.c | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/cmd/panic.c b/cmd/panic.c
+index f13b3f094fab..197e2d0870ff 100644
+--- a/cmd/panic.c
++++ b/cmd/panic.c
+@@ -11,7 +11,7 @@ static int do_panic(struct cmd_tbl *cmdtp, int flag, int argc,
+ {
+       char *text = (argc < 2) ? "" : argv[1];
+-      panic(text);
++      panic("%s\n", text);
+       return CMD_RET_SUCCESS;
+ }
+diff --git a/cmd/version.c b/cmd/version.c
+index 3686b8733249..35b52c48171d 100644
 --- a/cmd/version.c
 +++ b/cmd/version.c
-@@ -18,7 +18,7 @@ static int do_version(cmd_tbl_t *cmdtp,
+@@ -19,7 +19,7 @@ static int do_version(struct cmd_tbl *cmdtp, int flag, int argc,
  {
        char buf[DISPLAY_OPTIONS_BANNER_LENGTH];
  
 -      printf(display_options_get_banner(false, buf, sizeof(buf)));
-+      printf("%s",display_options_get_banner(false, buf, sizeof(buf)));
++      printf("%s", display_options_get_banner(false, buf, sizeof(buf)));
  #ifdef CC_VERSION_STRING
        puts(CC_VERSION_STRING "\n");
  #endif
+diff --git a/drivers/pinctrl/pinctrl-uclass.c b/drivers/pinctrl/pinctrl-uclass.c
+index b0f30aa1f758..aa62a890609a 100644
 --- a/drivers/pinctrl/pinctrl-uclass.c
 +++ b/drivers/pinctrl/pinctrl-uclass.c
-@@ -368,7 +368,7 @@ int pinctrl_get_pin_name(struct udevice
+@@ -371,7 +371,7 @@ int pinctrl_get_pin_name(struct udevice *dev, int selector, char *buf,
        if (!ops->get_pin_name)
                return -ENOSYS;
  
  
        return 0;
  }
---- a/lib/efi_loader/efi_variable.c
-+++ b/lib/efi_loader/efi_variable.c
-@@ -522,7 +522,7 @@ efi_status_t EFIAPI efi_set_variable(u16
-       if (old_size)
-               /* APPEND_WRITE */
--              s += sprintf(s, old_val);
-+              s += sprintf(s, "%s", old_val);
-       else
-               s += sprintf(s, "(blob)");
+-- 
+2.33.0
+
diff --git a/package/boot/uboot-at91/patches/010-fix_dtc_compilation_on_host_gcc10.patch b/package/boot/uboot-at91/patches/010-fix_dtc_compilation_on_host_gcc10.patch
deleted file mode 100644 (file)
index 6abb151..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-From e33a814e772cdc36436c8c188d8c42d019fda639 Mon Sep 17 00:00:00 2001
-From: Dirk Mueller <dmueller@suse.com>
-Date: Tue, 14 Jan 2020 18:53:41 +0100
-Subject: [PATCH] scripts/dtc: Remove redundant YYLOC global declaration
-
-gcc 10 will default to -fno-common, which causes this error at link
-time:
-
-  (.text+0x0): multiple definition of `yylloc'; dtc-lexer.lex.o (symbol from plugin):(.text+0x0): first defined here
-
-This is because both dtc-lexer as well as dtc-parser define the same
-global symbol yyloc. Before with -fcommon those were merged into one
-defintion. The proper solution would be to to mark this as "extern",
-however that leads to:
-
-  dtc-lexer.l:26:16: error: redundant redeclaration of 'yylloc' [-Werror=redundant-decls]
-   26 | extern YYLTYPE yylloc;
-      |                ^~~~~~
-In file included from dtc-lexer.l:24:
-dtc-parser.tab.h:127:16: note: previous declaration of 'yylloc' was here
-  127 | extern YYLTYPE yylloc;
-      |                ^~~~~~
-cc1: all warnings being treated as errors
-
-which means the declaration is completely redundant and can just be
-dropped.
-
-Signed-off-by: Dirk Mueller <dmueller@suse.com>
-Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
-[robh: cherry-pick from upstream]
-Cc: stable@vger.kernel.org
-Signed-off-by: Rob Herring <robh@kernel.org>
----
- scripts/dtc/dtc-lexer.l | 1 -
- 1 file changed, 1 deletion(-)
-
---- a/scripts/dtc/dtc-lexer.l
-+++ b/scripts/dtc/dtc-lexer.l
-@@ -38,7 +38,6 @@ LINECOMMENT  "//".*\n
- #include "srcpos.h"
- #include "dtc-parser.tab.h"
--YYLTYPE yylloc;
- extern bool treesource_error;
- /* CAUTION: this will stop working if we ever use yyless() or yyunput() */