ath79: add support for Fritz!Box 4020
authorDavid Bauer <mail@david-bauer.net>
Sat, 18 Aug 2018 16:30:46 +0000 (18:30 +0200)
committerMathias Kresin <dev@kresin.me>
Sun, 19 Aug 2018 16:52:22 +0000 (18:52 +0200)
This commit adds support for the AVM Fritz!Box 4020 WiFi-router.

SoC:   Qualcomm Atheros QCA9561 (Dragonfly) 750MHz
RAM:   Winbond W971GG6KB-25
FLASH: Macronix MX25L12835F
WiFi:  QCA9561 b/g/n 3x3 450Mbit/s
USB:   1x USB 2.0
IN:    WPS button, WiFi button
OUT:   Power LED green, Internet LED green, WLAN LED green,
       LAN LED green, INFO LED green, INFO LED red
UART:  Header Next to Black metal shield
       Pinout is 3.3V - RX - TX - GND (Square Pad is 3.3V)
       The Serial setting is 115200-8-N-1.

Tested and working:
 - Ethernet (LAN + WAN)
 - WiFi (correct MAC)
 - Installation via EVA bootloader
 - OpenWRT sysupgrade
 - Buttons
 - LEDs

The USB port doesn't work. Both Root Hubs are detected as having 0 Ports:

[    3.670807] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.723267] usbcore: registered new interface driver usbfs
[    3.729058] usbcore: registered new interface driver hub
[    3.734616] usbcore: registered new device driver usb
[    3.744181] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.758357] SCSI subsystem initialized
[    3.766026] ehci-platform: EHCI generic platform driver
[    3.771548] ehci-platform ehci-platform.0: EHCI Host Controller
[    3.777708] ehci-platform ehci-platform.0: new USB bus registered, assigned bus number 1
[    3.788169] ehci-platform ehci-platform.0: irq 48, io mem 0x1b000000
[    3.816647] ehci-platform ehci-platform.0: USB 2.0 started, EHCI 0.00
[    3.824001] hub 1-0:1.0: USB hub found
[    3.828219] hub 1-0:1.0: config failed, hub doesn't have any ports! (err -19)
[    3.835825] ehci-platform ehci-platform.1: EHCI Host Controller
[    3.842009] ehci-platform ehci-platform.1: new USB bus registered, assigned bus number 2
[    3.852481] ehci-platform ehci-platform.1: irq 49, io mem 0x1b400000
[    3.886631] ehci-platform ehci-platform.1: USB 2.0 started, EHCI 0.00
[    3.894011] hub 2-0:1.0: USB hub found
[    3.898190] hub 2-0:1.0: config failed, hub doesn't have any ports! (err -19)
[    3.908928] usbcore: registered new interface driver usb-storage
[    3.915634] kmodloader: done loading kernel modules from /etc/modules-boot.d/*

A few words about the shift-register:

AVM used a trick to control the shift-register for the LEDs with only 2
pins, SERCLK and MOSI. Q7S, normally used for daisy-chaining multiple
shift-registers, pulls the latch, moving the shift register-state to
the storage register. It also pulls down MR (normally pulled up) to
clear the storage register, so the latch gets released and will not be
pulled by the remaining bits in the shift-register. Shift register is
all-zero after this.

For that we need to make sure output 7 is set to high on driver probe.
We accomplish this by using gpio-hogging.

Installation via EVA:
In the first seconds after Power is connected, the bootloader will
listen for FTP connections on 169.254.157.1 (Might also be 192.168.178.1).
Firmware can be uploaded like following:

  ftp> quote USER adam2
  ftp> quote PASS adam2
  ftp> binary
  ftp> debug
  ftp> passive
  ftp> quote MEDIA FLSH
  ftp> put openwrt-sysupgrade.bin mtd1

Note that this procedure might take up to two minutes. After transfer is
complete you need to powercycle the device to boot OpenWRT.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/dts/qca9561_avm_fritz4020.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 73f350cae27a475c670525d34f3e797ee9eb641a..9d63254a6799e6f22e01a34726726e75843719fa 100755 (executable)
@@ -17,6 +17,10 @@ avm,fritz300e)
        ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssi3" "wlan0" "60" "100"
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssi4" "wlan0" "80" "100"
        ;;
+avm,fritz4020)
+       ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
+       ucidef_set_led_switch "lan" "LAN" "$boardname:green:lan" "switch0" "0x1E"
+       ;;
 buffalo,whr-g301n)
        ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
        ucidef_set_led_switch "lan1" "LAN1" "$boardname:green:lan1" "switch0" "0x02"
index 0db7ad4c5cc36b53bc592a218f43fec28fec9f3c..10d0b74027636fdca1d0a7222c68a5e7f3b63544 100755 (executable)
@@ -44,6 +44,7 @@ ath79_setup_interfaces()
        etactica,eg200)
                ucidef_set_interface_lan "eth0" "dhcp"
                ;;
+       avm,fritz4020|\
        glinet,ar150|\
        glinet,ar300m)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
@@ -156,6 +157,10 @@ ath79_setup_macs()
        avm,fritz300e)
                lan_mac=$(fritz_tffs -n maca -i $(find_mtd_part "tffs (1)"))
                ;;
+       avm,fritz4020)
+               lan_mac=$(fritz_tffs -n maca -i $(find_mtd_part "tffs (1)"))
+               wan_mac=$(fritz_tffs -n macb -i $(find_mtd_part "tffs (1)"))
+               ;;
        dlink,dir-825-b1)
                lan_mac=$(mtd_get_mac_text "caldata" 65440)
                wan_mac=$(mtd_get_mac_text "caldata" 65460)
index f668a82fa22cb6532d6d418ea91e32df9af846fa..9cbce4cecdffce86059d7d4836d4fee24cee3eec 100644 (file)
@@ -97,6 +97,9 @@ board=$(board_name)
 case "$FIRMWARE" in
 "ath9k-eeprom-ahb-18100000.wmac.bin")
        case $board in
+       avm,fritz4020)
+               ath9k_eeprom_extract_reverse "urlader" 5441 1088
+               ;;
        iodata,wn-ac1167dgr|\
        iodata,wn-ac1600dgr2)
                ath9k_eeprom_extract "art" 4096 1088
diff --git a/target/linux/ath79/dts/qca9561_avm_fritz4020.dts b/target/linux/ath79/dts/qca9561_avm_fritz4020.dts
new file mode 100644 (file)
index 0000000..6b2a35c
--- /dev/null
@@ -0,0 +1,180 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       compatible = "avm,fritz4020", "qca,qca9560";
+       model = "AVM FRITZ!Box 4020";
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &info_red;
+               led-running = &power;
+               led-upgrade = &info_red;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       led_spi {
+               compatible = "spi-gpio";
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               gpio-sck = <&gpio 20 GPIO_ACTIVE_HIGH>;
+               gpio-mosi = <&gpio 19 GPIO_ACTIVE_HIGH>;
+               num-chipselects = <0>;
+
+               led_gpio: led_gpio@0 {
+                       compatible = "fairchild,74hc595";
+                       reg = <0>;
+                       gpio-controller;
+                       #gpio-cells = <2>;
+                       registers-number = <1>;
+                       lines-initial-states = /bits/ 8 <0xff>;
+                       spi-max-frequency = <10000000>;
+
+                       gpio_latch_bit {
+                               gpio-hog;
+                               gpios = <7 GPIO_ACTIVE_HIGH>;
+                               output-high;
+                               line-name = "gpio-latch-bit";
+                       };
+
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power: power {
+                       label = "fritz4020:green:power";
+                       gpios = <&led_gpio 2 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wlan {
+                       label = "fritz4020:green:wlan";
+                       gpios = <&led_gpio 3 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+                       default-state = "off";
+               };
+
+               lan {
+                       label = "fritz4020:green:lan";
+                       gpios = <&led_gpio 0 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               wan {
+                       label = "fritz4020:green:wan";
+                       gpios = <&led_gpio 4 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               info {
+                       label = "fritz4020:green:info";
+                       gpios = <&led_gpio 6 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               info_red: info_red {
+                       label = "fritz4020:red:info";
+                       gpios = <&led_gpio 1 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <100>;
+
+               wps_button {
+                       label = "WPS button";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan_button {
+                       label = "WLAN button";
+                       linux,code = <KEY_RFKILL>;
+                       gpios = <&gpio 21 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "urlader";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@1 {
+                               label = "firmware";
+                               reg = <0x020000 0xee0000>;
+                       };
+
+                       partition@2 {
+                               label = "tffs (1)";
+                               reg = <0xf00000 0x080000>;
+                               read-only;
+                       };
+
+                       partition@3 {
+                               label = "tffs (2)";
+                               reg = <0xf80000 0x080000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-mode = "mii";
+       phy-handle = <&swphy0>;
+
+       gmac-config {
+               device = <&gmac>;
+
+               switch-phy-addr-swap = <1>;
+               switch-phy-swap = <1>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+       qca,no-eeprom;
+};
index b3eaee48b75e015249c864b4a414ded879af5644..eb71c641a0555496908538c2ac1eeed751e181d7 100644 (file)
@@ -13,6 +13,19 @@ define Device/avm_fritz300e
 endef
 TARGET_DEVICES += avm_fritz300e
 
+define Device/avm_fritz4020
+  ATH_SOC := qca9561
+  DEVICE_TITLE := AVM FRITZ!Box 4020
+  IMAGE_SIZE := 15232k
+  KERNEL := kernel-bin | append-dtb | lzma | eva-image
+  KERNEL_INITRAMFS := $$(KERNEL)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
+      append-squashfs-fakeroot-be | pad-to 256 | \
+      append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+  DEVICE_PACKAGES := fritz-tffs
+endef
+TARGET_DEVICES += avm_fritz4020
+
 define Device/buffalo_wzr-hp-g450h
   ATH_SOC := ar7242
   DEVICE_TITLE := Buffalo WZR-HP-G450H