kernel: net: add support for kernel tls
authorTiago Gaspar <tiagogaspar8@gmail.com>
Wed, 12 Apr 2023 12:53:33 +0000 (13:53 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 20 May 2023 13:19:14 +0000 (15:19 +0200)
Add ktls (Kernel TLS) kmods to enable TLS support
in kernel (allowing TLS offload when the network
card supports it)

Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
(added disabled symbols)
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/netsupport.mk
target/linux/generic/config-5.15

index 4653b8256502ea105166378b5a1f53ba003b62dd..b73928980928f3b5e7874dd794e5789337e5c8f7 100644 (file)
@@ -46,6 +46,7 @@ define KernelPackage/bonding
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Ethernet bonding driver
   KCONFIG:=CONFIG_BONDING
+  DEPENDS:=PACKAGE_kmod-tls:kmod-tls
   FILES:=$(LINUX_DIR)/drivers/net/bonding/bonding.ko
   AUTOLOAD:=$(call AutoLoad,40,bonding)
   MODPARAMS.bonding:=max_bonds=0
@@ -1042,6 +1043,24 @@ endef
 
 $(eval $(call KernelPackage,tcp-bbr))
 
+define KernelPackage/tls
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=In-kernel TLS Support with HW Offload
+  KCONFIG:=CONFIG_TLS \
+       CONFIG_TLS_DEVICE=y
+  FILES:=$(LINUX_DIR)/net/tls/tls.ko
+  AUTOLOAD:=$(call AutoProbe,tls)
+endef
+
+define KernelPackage/tls/description
+ Kernel module for in-kernel TLS protocol support and hw offload
+ (to supported interfaces).
+ This allows symmetric encryption handling of the TLS protocol to
+ be done in-kernel and it's HW offload when available.
+endef
+
+$(eval $(call KernelPackage,tls))
+
 
 define KernelPackage/tcp-hybla
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
index 4c35281b54063929428f23ef9592dac1db6f1eb2..f13af8ba268f2f2c23120dfeca367e59c9a6d76f 100644 (file)
@@ -6571,6 +6571,8 @@ CONFIG_TINY_RCU=y
 # CONFIG_TI_TSC2046 is not set
 # CONFIG_TLAN is not set
 # CONFIG_TLS is not set
+# CONFIG_TLS_DEVICE is not set
+# CONFIG_TLS_TOE is not set
 # CONFIG_TMD_HERMES is not set
 # CONFIG_TMP006 is not set
 # CONFIG_TMP007 is not set