include/toplevel: set env GIT_ASKPASS=/bin/true
authorAlexander Couzens <lynxis@fe80.eu>
Wed, 7 Jun 2017 21:56:19 +0000 (23:56 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 8 Jun 2017 21:02:37 +0000 (23:02 +0200)
When git-https request a service (e.g. github) which ask for credentials
git will pass this request to the user resulting download.pl to wait for
user input. Set GIT_ASKPASS to stop asking.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
include/toplevel.mk

index c90670bee62ee7912a1c08c2f582e6b0a074ceca..77b04aea8a2724ee62d8cecbd1213105a655d424 100644 (file)
@@ -23,6 +23,7 @@ HOSTCC ?= $(CC)
 export REVISION
 export SOURCE_DATE_EPOCH
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
+export GIT_ASKPASS:=/bin/true
 export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))
 
 # prevent perforce from messing with the patch utility