kernel: bump 4.9 to 4.9.181
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 11 Jun 2019 12:06:37 +0000 (14:06 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 12 Jun 2019 14:04:25 +0000 (16:04 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/509-MIPS-ath79-process-board-kernel-option.patch
target/linux/ar71xx/patches-4.9/604-MIPS-ath79-no-of.patch
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.9/950-0100-staging-vchi-Convert-to-current-get_user_pages-argum.patch
target/linux/brcm2708/patches-4.9/950-0101-staging-vchi-Update-for-rename-of-page_cache_release.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/ixp4xx/patches-4.9/160-delayed_uart_io.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 0f1dfcec2708252fa61c76a58419d122fa6c418e..b291044547025154535ca9e72db7df81fd43a4d9 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .180
+LINUX_VERSION-4.9 = .181
 LINUX_VERSION-4.14 = .123
 
-LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
+LINUX_KERNEL_HASH-4.9.181 = 8fcd223e11cba322801bc38cdb8b581d64c0115f585dcb6604de8561b574fced
 LINUX_KERNEL_HASH-4.14.123 = 25f58cb56bde388ac9bcee984f5f2d0ca094b0a8af6b92ad1f5b2fd0e6725b85
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 139b09c1b0e7b71d07cfbaa64d0e21c05cace700..3091ab69b60e56079a22ed2c3c3015ed000c5cf4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -277,6 +277,8 @@ void __init plat_time_init(void)
+@@ -283,6 +283,8 @@ void __init plat_time_init(void)
        mips_hpt_frequency = cpu_clk_rate / 2;
  }
  
index ba855e15008ea8f660b721ea98992bd206e0f07b..89dd32a7c10c2a28c5eada26658650e9364f1305 100644 (file)
@@ -10,7 +10,7 @@
  
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -190,16 +190,20 @@ unsigned int get_c0_compare_int(void)
+@@ -196,16 +196,20 @@ unsigned int get_c0_compare_int(void)
  
  void __init plat_mem_setup(void)
  {
@@ -31,7 +31,7 @@
  
        if (mips_machtype != ATH79_MACH_GENERIC_OF) {
                ath79_reset_base = ioremap_nocache(AR71XX_RESET_BASE,
-@@ -295,17 +299,21 @@ static int __init ath79_setup(void)
+@@ -301,17 +305,21 @@ static int __init ath79_setup(void)
  
  arch_initcall(ath79_setup);
  
index fc994edc4e59aae23c1ac74ca5b337aa96b52704..67b6b785f73e0e5a5f0a0274ae7836eb5f28bd10 100644 (file)
                memcpy(p, foc->val, foc->len);
 --- a/net/ipv4/igmp.c
 +++ b/net/ipv4/igmp.c
-@@ -537,7 +537,7 @@ static struct sk_buff *add_grec(struct s
+@@ -548,7 +548,7 @@ static struct sk_buff *add_grec(struct s
                if (!skb)
                        return NULL;
                psrc = (__be32 *)skb_put(skb, sizeof(__be32));
index e5038ab647e4ba4d71de00f11d7bb95608ff5b05..358febbb0bc910892b15a15090d8cca554ac0cae 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
 
 --- a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_2835_arm.c
 +++ b/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_2835_arm.c
-@@ -426,7 +426,7 @@ create_pagelist(char __user *buf, size_t
+@@ -435,7 +435,7 @@ create_pagelist(char __user *buf, size_t
                *need_release = 0; /* do not try and release vmalloc pages */
        } else {
                down_read(&task->mm->mmap_sem);
index 5cc5ff16514a42bc39a0d8ea7ae3ce9fc5998f58..6626e7fbe57c1a5bc7bdc4b5e72420d9c6767752 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
 
 --- a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_2835_arm.c
 +++ b/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_2835_arm.c
-@@ -444,7 +444,7 @@ create_pagelist(char __user *buf, size_t
+@@ -453,7 +453,7 @@ create_pagelist(char __user *buf, size_t
                        while (actual_pages > 0)
                        {
                                actual_pages--;
@@ -21,7 +21,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
                        }
                        kfree(pagelist);
                        if (actual_pages == 0)
-@@ -585,7 +585,7 @@ free_pagelist(PAGELIST_T *pagelist, int
+@@ -594,7 +594,7 @@ free_pagelist(PAGELIST_T *pagelist, int
                                offset = 0;
                                set_page_dirty(pg);
                        }
index f2f1f6f81e7a008b4c27fa6286d733cba92104a6..6c1f762e8d6f44a3ceabdec6a28f5b8c1818882f 100644 (file)
@@ -399,7 +399,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                        /* bnx2x_has_rx_work() reads the status block,
 --- a/drivers/net/ethernet/broadcom/bnxt/bnxt.c
 +++ b/drivers/net/ethernet/broadcom/bnxt/bnxt.c
-@@ -1797,7 +1797,7 @@ static int bnxt_poll_nitroa0(struct napi
+@@ -1799,7 +1799,7 @@ static int bnxt_poll_nitroa0(struct napi
        }
  
        if (!bnxt_has_work(bp, cpr) && rx_pkts < budget) {
@@ -819,7 +819,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/ethernet/marvell/mvpp2.c
 +++ b/drivers/net/ethernet/marvell/mvpp2.c
-@@ -5406,7 +5406,7 @@ static int mvpp2_poll(struct napi_struct
+@@ -5404,7 +5404,7 @@ static int mvpp2_poll(struct napi_struct
  
        if (budget > 0) {
                cause_rx = 0;
index 00a5309dcf7fcae8d6d21c266329d2892ef96004..ed3a40de9c522cf13a1227ff424b4550bb4e8649 100644 (file)
@@ -18,7 +18,7 @@
                uart->capabilities      = up->capabilities;
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -2260,6 +2260,7 @@ uart_report_port(struct uart_driver *drv
+@@ -2254,6 +2254,7 @@ uart_report_port(struct uart_driver *drv
                snprintf(address, sizeof(address),
                         "I/O 0x%lx offset 0x%x", port->iobase, port->hub6);
                break;
@@ -26,7 +26,7 @@
        case UPIO_MEM:
        case UPIO_MEM16:
        case UPIO_MEM32:
-@@ -2924,6 +2925,7 @@ int uart_match_port(struct uart_port *po
+@@ -2926,6 +2927,7 @@ int uart_match_port(struct uart_port *po
        case UPIO_HUB6:
                return (port1->iobase == port2->iobase) &&
                       (port1->hub6   == port2->hub6);
index 953f02de6c6f83749d9b05d826515e5c154ddde0..06d2c9653c3201b780bcba31f4678f24855c9787 100644 (file)
@@ -1439,7 +1439,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -1855,14 +1855,17 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1859,14 +1859,17 @@ static int finish_td(struct xhci_hcd *xh
        union xhci_trb *event_trb, struct xhci_transfer_event *event,
        struct xhci_virt_ep *ep, int *status, bool skip)
  {
@@ -1457,7 +1457,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        u32 trb_comp_code;
  
        slot_id = TRB_TO_SLOT_ID(le32_to_cpu(event->flags));
-@@ -1888,13 +1891,29 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1892,13 +1895,29 @@ static int finish_td(struct xhci_hcd *xh
        if (trb_comp_code == COMP_STALL ||
                xhci_requires_manual_halt_cleanup(xhci, ep_ctx,
                                                trb_comp_code)) {
@@ -1494,7 +1494,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                while (ep_ring->dequeue != td->last_trb)
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1609,14 +1609,38 @@ int xhci_urb_dequeue(struct usb_hcd *hcd
+@@ -1607,14 +1607,38 @@ int xhci_urb_dequeue(struct usb_hcd *hcd
                        ret = -ENOMEM;
                        goto done;
                }