kernel: make kmod-hwmon-core selected by dependent modules
authorSungbo Eo <mans0n@gorani.run>
Thu, 5 Mar 2020 14:22:47 +0000 (23:22 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 13 Mar 2020 13:23:33 +0000 (14:23 +0100)
Currently kmod-hwmon-* will not get into images unless kmod-hwmon-core is added
to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to
"select", we do not have the issue anymore.

Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES
and similar variables, as it is now pulled by dependent modules such as:
- kmod-hwmon-gpiofan
- kmod-hwmon-lm63
- kmod-hwmon-lm75
- kmod-hwmon-lm85
- kmod-hwmon-lm90

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
[do not touch ar71xx, adjust line wrapping]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/kernel/hwmon-gsc/Makefile
package/kernel/linux/modules/hwmon.mk
target/linux/kirkwood/image/Makefile
target/linux/mpc85xx/image/Makefile
target/linux/oxnas/image/ox820.mk
target/linux/oxnas/ox820/profiles/00-default.mk

index 454f685f8f409f9ac1a5edd6b59dd00f77400081..95f6fab4c094d1682257a657a8c78fc6da2790aa 100644 (file)
@@ -8,7 +8,7 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/hwmon-gsc
   SUBMENU:=Hardware Monitoring Support
-  DEPENDS:=@TARGET_imx6||TARGET_cns3xxx kmod-hwmon-core +kmod-i2c-core
+  DEPENDS:=@TARGET_imx6||TARGET_cns3xxx +kmod-hwmon-core +kmod-i2c-core
   TITLE:=Driver for the Gateworks System Controller
   AUTOLOAD:=$(call AutoLoad,60,gsc)
   FILES:=$(PKG_BUILD_DIR)/gsc.ko
index c0a477856e9d74a5b710243ee76bebf84b662a10..73b448022ded9ac92fafc817d2067d085945cb52 100644 (file)
@@ -26,7 +26,7 @@ $(eval $(call KernelPackage,hwmon-core))
 
 define AddDepends/hwmon
   SUBMENU:=$(HWMON_MENU)
-  DEPENDS:=kmod-hwmon-core $(1)
+  DEPENDS:=+kmod-hwmon-core $(1)
 endef
 
 define KernelPackage/hwmon-ads1015
index 7de62d13ca1d4fe9df97556f15fd1729dc46c752..67dd53af702703d67027bc453f10d65047af8f53 100644 (file)
@@ -65,7 +65,7 @@ define Device/iom_ix2-200
   DEVICE_VENDOR := Iomega
   DEVICE_MODEL := StorCenter ix2-200
   DEVICE_DTS := kirkwood-iomega_ix2_200
-  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-hwmon-core kmod-hwmon-lm63
+  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-hwmon-lm63
   DEVICE_TYPE:=nas
   PAGESIZE := 512
   SUBPAGESIZE := 256
@@ -137,8 +137,7 @@ TARGET_DEVICES += seagate_goflexhome
 define Device/zyxel_nsa310b
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NSA310b
-  DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-core \
-       kmod-hwmon-lm85
+  DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
   BOARD_NAME := nsa310b
 endef
 TARGET_DEVICES += zyxel_nsa310b
index 98fe51c7e9e31c63a2e1e4b0972244eeeda4456f..40002c13c47537194b76f27b55366ff7b6910c69 100644 (file)
@@ -111,7 +111,7 @@ define Device/freescale_p2020rdb
   DEVICE_VENDOR := Freescale
   DEVICE_MODEL := P2020RDB
   DEVICE_DTS_DIR := $(DTS_DIR)/fsl
-  DEVICE_PACKAGES := kmod-hwmon-core kmod-hwmon-lm90 kmod-rtc-ds1307 \
+  DEVICE_PACKAGES := kmod-hwmon-lm90 kmod-rtc-ds1307 \
        kmod-gpio-pca953x kmod-eeprom-at24
   BLOCKSIZE := 128k
   KERNEL := kernel-bin | gzip | \
index 41ab3e230a6750f8952b680f2f88307bdce1ec31..c0e0733f8e6d0d776bb102fdf944247f944d7fb5 100644 (file)
@@ -71,7 +71,7 @@ define Device/shuttle_kd20
   KERNEL_INITRAMFS = kernel-bin | append-dtb | uImage none | omninas-factory | encrypt-3des sohmuntitnlaes
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-usb-ledtrig-usbport \
                      kmod-usb3 kmod-i2c-gpio kmod-rtc-pcf8563 kmod-gpio-beeper \
-                     kmod-hwmon-core kmod-hwmon-gpiofan \
+                     kmod-hwmon-gpiofan \
                      kmod-md-mod kmod-md-raid0 kmod-md-raid1 kmod-fs-ext4 kmod-fs-xfs
 endef
 TARGET_DEVICES += shuttle_kd20
index fedf730088442f6c642f2546019b1ae93423447c..c68d7cd9d60f8e0f9b2419994de1db6fa8166f37 100644 (file)
@@ -9,9 +9,8 @@ define Profile/Default
        NAME:=Default Profile
        PRIORITY:=1
        PACKAGES:=\
-               kmod-i2c-gpio kmod-gpio-beeper kmod-hwmon-core \
-               kmod-hwmon-gpiofan kmod-rtc-pcf8563 kmod-rtc-ds1307 \
-               kmod-usb3
+               kmod-i2c-gpio kmod-gpio-beeper kmod-hwmon-gpiofan \
+               kmod-rtc-pcf8563 kmod-rtc-ds1307 kmod-usb3
 endef
 
 define Profile/Default/Description