gre: add ipv6 parameter to gre interfaces
authorAlin Nastac <alin.nastac@gmail.com>
Tue, 12 Nov 2019 14:11:00 +0000 (15:11 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Mon, 2 Dec 2019 20:52:33 +0000 (21:52 +0100)
IPv6 protocol is enabled on all gre interfaces, but gre(v6)tap
interfaces are usually added to a bridge interface, in which case
IPv6 should be enabled only on the bridge interface.

Signed-off-by: Alin Nastac <alin.nastac@gmail.com>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
package/network/config/gre/Makefile
package/network/config/gre/files/gre.sh

index e3a79e11e4a4d81b2096a91c381cd6f819163ad1..ca19f5d47c1c247b44e80227a9fb9c3598c94fe1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 3414ed304796ea35911ecb8b27f397d530ad7405..eb3df5b48c874c7e14b32bd53bb27a8ff0854684 100755 (executable)
@@ -13,8 +13,8 @@ gre_generic_setup() {
        local local="$3"
        local remote="$4"
        local link="$5"
-       local mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
-       json_get_vars mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
+       local mtu ipv6 ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
+       json_get_vars mtu ipv6 ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
 
        [ -z "$multicast" ] && multicast=1
 
@@ -23,6 +23,7 @@ gre_generic_setup() {
        proto_add_tunnel
        json_add_string mode "$mode"
        json_add_int mtu "${mtu:-1280}"
+       json_add_boolean ipv6 "${ipv6:-1}"
        [ -n "$df" ] && json_add_boolean df "$df"
        [ -n "$ttl" ] && json_add_int ttl "$ttl"
        [ -n "$tos" ] && json_add_string tos "$tos"
@@ -248,6 +249,7 @@ gre_generic_init_config() {
        available=1
 
        proto_config_add_int "mtu"
+       proto_config_add_boolean "ipv6"
        proto_config_add_int "ttl"
        proto_config_add_string "tos"
        proto_config_add_string "tunlink"