kernel: bump 4.9 to 4.9.192
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 11 Sep 2019 09:23:15 +0000 (11:23 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 13 Sep 2019 14:04:00 +0000 (16:04 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/024-3-tcp-tsq-add-shortcut-in-tcp_tasklet_func.patch
target/linux/generic/backport-4.9/024-5-tcp-tsq-add-a-shortcut-in-tcp_small_queue_check.patch
target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
target/linux/generic/backport-4.9/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch

index 009feeacfe928836de1789f43182e7e153a0c6a5..fb7b8a8c39a6342058a6c6376ed2f5824c394b8d 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .191
+LINUX_VERSION-4.9 = .192
 LINUX_VERSION-4.14 = .142
 
 LINUX_VERSION-4.14 = .142
 
-LINUX_KERNEL_HASH-4.9.191 = ded4b87406deb67112b25a2283e8b5c89c2b47e2de14a97acda57f74cd38b7bc
+LINUX_KERNEL_HASH-4.9.192 = 7a1a300cce70a4fd0d49b7fff7b1673159b61c4040c5a7c08ea333a7cb328d54
 LINUX_KERNEL_HASH-4.14.142 = e67ba535991170a8383be68203af7d9b4262474ceeff2f9afedeac6043b590f3
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 LINUX_KERNEL_HASH-4.14.142 = e67ba535991170a8383be68203af7d9b4262474ceeff2f9afedeac6043b590f3
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index caa8cc9be230f57bbdf7a32df3de07acbac17166..80b2c3db1c1010a910cf4e9f6c11ac4fcd1ea7d0 100644 (file)
@@ -60,7 +60,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                nval = cmpxchg(&tp->tsq_flags, oval, nval);
                if (nval != oval)
                        continue;
                nval = cmpxchg(&tp->tsq_flags, oval, nval);
                if (nval != oval)
                        continue;
-@@ -2235,6 +2235,8 @@ static bool tcp_write_xmit(struct sock *
+@@ -2236,6 +2236,8 @@ static bool tcp_write_xmit(struct sock *
                    unlikely(tso_fragment(sk, skb, limit, mss_now, gfp)))
                        break;
  
                    unlikely(tso_fragment(sk, skb, limit, mss_now, gfp)))
                        break;
  
index c577d4e72fe8975522ecf4f1c5fb5bc183459c5a..7cfc819ecc8bacf836a7ac1f635f8ad51734f0b1 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
 
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -2140,6 +2140,15 @@ static bool tcp_small_queue_check(struct
+@@ -2141,6 +2141,15 @@ static bool tcp_small_queue_check(struct
        limit <<= factor;
  
        if (atomic_read(&sk->sk_wmem_alloc) > limit) {
        limit <<= factor;
  
        if (atomic_read(&sk->sk_wmem_alloc) > limit) {
index edb933b8c4ba1529aa2d0042c72e5a668369bdd0..eef1a1cc890843a26899d8791da26d97a758bc52 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (nval != oval)
                        continue;
  
                if (nval != oval)
                        continue;
  
-@@ -2149,7 +2149,7 @@ static bool tcp_small_queue_check(struct
+@@ -2150,7 +2150,7 @@ static bool tcp_small_queue_check(struct
                    skb->prev == sk->sk_write_queue.next)
                        return false;
  
                    skb->prev == sk->sk_write_queue.next)
                        return false;
  
@@ -123,7 +123,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                /* It is possible TX completion already happened
                 * before we set TSQ_THROTTLED, so we must
                 * test again the condition.
                /* It is possible TX completion already happened
                 * before we set TSQ_THROTTLED, so we must
                 * test again the condition.
-@@ -2247,8 +2247,8 @@ static bool tcp_write_xmit(struct sock *
+@@ -2248,8 +2248,8 @@ static bool tcp_write_xmit(struct sock *
                    unlikely(tso_fragment(sk, skb, limit, mss_now, gfp)))
                        break;
  
                    unlikely(tso_fragment(sk, skb, limit, mss_now, gfp)))
                        break;
  
@@ -134,7 +134,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (tcp_small_queue_check(sk, skb, 0))
                        break;
  
                if (tcp_small_queue_check(sk, skb, 0))
                        break;
  
-@@ -3559,8 +3559,6 @@ void __tcp_send_ack(struct sock *sk, u32
+@@ -3560,8 +3560,6 @@ void __tcp_send_ack(struct sock *sk, u32
        /* We do not want pure acks influencing TCP Small Queues or fq/pacing
         * too much.
         * SKB_TRUESIZE(max(1 .. 66, MAX_TCP_HEADER)) is unfortunately ~784
        /* We do not want pure acks influencing TCP Small Queues or fq/pacing
         * too much.
         * SKB_TRUESIZE(max(1 .. 66, MAX_TCP_HEADER)) is unfortunately ~784
index 15856d3a89bd1629cd75eea1810826157d635357..1543934e452e05e6869b1802410fc7ba019b6ef9 100644 (file)
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2136,7 +2136,7 @@ static bool tcp_small_queue_check(struct
+@@ -2137,7 +2137,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
  {
        unsigned int limit;
  
index bef1e8692c5d8628416089180d4521cfbb09b1ce..b9f018db9d8c4793041ee6d9c808d273cb6024d6 100644 (file)
@@ -1238,7 +1238,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
 --- a/drivers/net/ethernet/tundra/tsi108_eth.c
 +++ b/drivers/net/ethernet/tundra/tsi108_eth.c
        }
 --- a/drivers/net/ethernet/tundra/tsi108_eth.c
 +++ b/drivers/net/ethernet/tundra/tsi108_eth.c
-@@ -887,7 +887,7 @@ static int tsi108_poll(struct napi_struc
+@@ -888,7 +888,7 @@ static int tsi108_poll(struct napi_struc
  
        if (num_received < budget) {
                data->rxpending = 0;
  
        if (num_received < budget) {
                data->rxpending = 0;