brcm47xx: Add edimax PS1208mfg support
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 2 Dec 2010 21:27:54 +0000 (21:27 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 2 Dec 2010 21:27:54 +0000 (21:27 +0000)
Thank you clemvangelis for the patches. (closes #7672)

SVN-Revision: 24217

package/broadcom-diag/src/diag.c
target/linux/brcm47xx/files-2.6.34/drivers/mtd/maps/bcm47xx-flash.c
target/linux/brcm47xx/files-2.6.36/drivers/mtd/maps/bcm47xx-flash.c
target/linux/brcm47xx/files-2.6.37/drivers/mtd/maps/bcm47xx-flash.c
target/linux/brcm47xx/image/Makefile
target/linux/brcm47xx/image/lzma-loader/src/decompress.c
target/linux/brcm47xx/profiles/PS-1208MFG.mk [new file with mode: 0644]
tools/firmware-utils/Makefile
tools/firmware-utils/src/trx2edips.c [new file with mode: 0644]

index 501b835f477ceb066d06f6e3ecf83848edbe6629..55dfa757ebced3eb887541574a91c4530a84d466 100644 (file)
@@ -138,6 +138,9 @@ enum {
 
        /* Microsoft */
        MN700,
+
+       /* Edimax */
+       PS1208MFG,
 };
 
 static void __init bcm4780_init(void) {
@@ -895,6 +898,17 @@ static struct platform_t __initdata platforms[] = {
                        { .name = "power",      .gpio = 1 << 6, .polarity = NORMAL },
                },
        },
+       /* Edimax */
+       [PS1208MFG] = {
+               .name   = "Edimax PS-1208MFG",
+               .buttons        = {
+                       { .name = "reset",      .gpio = 1 << 4 },
+               },
+               .leds     = {
+                       { .name = "status",     .gpio = 1 << 1, .polarity = NORMAL },
+                       { .name = "wlan",       .gpio = 1 << 0, .polarity = NORMAL },
+               },
+       },
 };
 
 static struct platform_t __init *platform_detect(void)
@@ -1121,9 +1135,13 @@ static struct platform_t __init *platform_detect(void)
        if (startswith(boardnum, "04FN")) /* SimpleTech SimpleShare */
                return &platforms[STI_NAS];
 
-       if (!strcmp(getvar("boardnum"), "10") && !strcmp(getvar("boardrev"), "0x13")) /* D-Link DWL-3150 */
+       if (!strcmp(boardnum, "10") && !strcmp(getvar("boardrev"), "0x13")) /* D-Link DWL-3150 */
                return &platforms[DWL3150];
 
+       if (!strcmp(boardnum, "01") && !strcmp(boardtype, "0x048e") && /* Edimax PS1208MFG */
+               !strcmp(getvar("status_gpio"), "1")) /* gpio based detection */
+               return &platforms[PS1208MFG];
+
        /* not found */
        return NULL;
 }
index 3159bf3f64f72ec553e5d12a22da543a6053c83f..4585c4f9ee8cc5d9cc58d2661e3c6c38c85c300a 100644 (file)
@@ -71,6 +71,15 @@ struct trx_header {
        u32 offsets[TRX_MAX_OFFSET];    /* Offsets of partitions from start of header */
 };
 
+/* for Edimax Print servers which use an additional header
+ * then the firmware on flash looks like :
+ * EDIMAX HEADER | TRX HEADER
+ * As this header is 12 bytes long we have to handle it
+ * and skip it to find the TRX header
+ */
+#define EDIMAX_PS_HEADER_MAGIC 0x36315350 /*  "PS16"  */
+#define EDIMAX_PS_HEADER_LEN   0xc /* 12 bytes long for edimax header */
+
 #define ROUNDUP(x, y) ((((x)+((y)-1))/(y))*(y))
 #define NVRAM_SPACE 0x8000
 #define WINDOW_ADDR 0x1fc00000
@@ -145,6 +154,15 @@ find_cfe_size(struct mtd_info *mtd, size_t size)
                    len != sizeof(buf))
                        continue;
 
+               if (le32_to_cpu(trx->magic) == EDIMAX_PS_HEADER_MAGIC) {
+                       if (mtd->read(mtd, off + EDIMAX_PS_HEADER_LEN,
+                           sizeof(buf), &len, buf) || len != sizeof(buf)) {
+                               continue;
+                       } else {
+                               printk(KERN_NOTICE"Found edimax header\n");
+                       }
+               }
+
                /* found a TRX header */
                if (le32_to_cpu(trx->magic) == TRX_MAGIC) {
                        goto found;
@@ -217,7 +235,7 @@ static int erase_write (struct mtd_info *mtd, unsigned long pos,
        remove_wait_queue(&wait_q, &wait);
 
        /*
-        * Next, writhe data to flash.
+        * Next, write data to flash.
         */
 
        ret = mtd->write (mtd, pos, len, &retlen, buf);
@@ -267,9 +285,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
 {
        struct trx_header trx, *trx2;
        unsigned char buf[512], *block;
-       int off, blocksize;
+       int off, blocksize, trxoff = 0;
        u32 i, crc = ~0;
        size_t len;
+       bool edimax = false;
 
        blocksize = mtd->erasesize;
        if (blocksize < 0x10000)
@@ -285,6 +304,19 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                    len != sizeof(trx))
                        continue;
 
+               /* found an edimax header */
+               if (le32_to_cpu(trx.magic) == EDIMAX_PS_HEADER_MAGIC) {
+                       /* read the correct trx header */
+                       if (mtd->read(mtd, off + EDIMAX_PS_HEADER_LEN,
+                           sizeof(trx), &len, (char *) &trx) ||
+                           len != sizeof(trx)) {
+                               continue;
+                       } else {
+                               printk(KERN_NOTICE"Found an edimax ps header\n");
+                               edimax = true;
+                       }
+               }
+
                /* found a TRX header */
                if (le32_to_cpu(trx.magic) == TRX_MAGIC) {
                        part->offset = le32_to_cpu(trx.offsets[2]) ? : 
@@ -293,6 +325,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
 
                        part->size -= part->offset;
                        part->offset += off;
+                       if (edimax) {
+                               off += EDIMAX_PS_HEADER_LEN;
+                               trxoff = EDIMAX_PS_HEADER_LEN;
+                       }
 
                        goto found;
                }
@@ -304,6 +340,7 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
        return -1;
 
  found:
+       printk(KERN_NOTICE"TRX offset : %lx\n", trxoff);
        if (part->size == 0)
                return 0;
        
@@ -328,7 +365,7 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                /* read first eraseblock from the trx */
                block = kmalloc(mtd->erasesize, GFP_KERNEL);
                trx2 = (struct trx_header *) block;
-               if (mtd->read(mtd, off, mtd->erasesize, &len, block) || len != mtd->erasesize) {
+               if (mtd->read(mtd, off - trxoff, mtd->erasesize, &len, block) || len != mtd->erasesize) {
                        printk("Error accessing the first trx eraseblock\n");
                        return 0;
                }
@@ -338,10 +375,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                printk("new trx = [0x%08x, 0x%08x, 0x%08x], len=0x%08x crc32=0x%08x\n",   trx.offsets[0],   trx.offsets[1],   trx.offsets[2],   trx.len, trx.crc32);
 
                /* Write updated trx header to the flash */
-               memcpy(block, &trx, sizeof(trx));
+               memcpy(block + trxoff, &trx, sizeof(trx));
                if (mtd->unlock)
-                       mtd->unlock(mtd, off, mtd->erasesize);
-               erase_write(mtd, off, mtd->erasesize, block);
+                       mtd->unlock(mtd, off - trxoff, mtd->erasesize);
+               erase_write(mtd, off - trxoff, mtd->erasesize, block);
                if (mtd->sync)
                        mtd->sync(mtd);
                kfree(block);
index 3159bf3f64f72ec553e5d12a22da543a6053c83f..4585c4f9ee8cc5d9cc58d2661e3c6c38c85c300a 100644 (file)
@@ -71,6 +71,15 @@ struct trx_header {
        u32 offsets[TRX_MAX_OFFSET];    /* Offsets of partitions from start of header */
 };
 
+/* for Edimax Print servers which use an additional header
+ * then the firmware on flash looks like :
+ * EDIMAX HEADER | TRX HEADER
+ * As this header is 12 bytes long we have to handle it
+ * and skip it to find the TRX header
+ */
+#define EDIMAX_PS_HEADER_MAGIC 0x36315350 /*  "PS16"  */
+#define EDIMAX_PS_HEADER_LEN   0xc /* 12 bytes long for edimax header */
+
 #define ROUNDUP(x, y) ((((x)+((y)-1))/(y))*(y))
 #define NVRAM_SPACE 0x8000
 #define WINDOW_ADDR 0x1fc00000
@@ -145,6 +154,15 @@ find_cfe_size(struct mtd_info *mtd, size_t size)
                    len != sizeof(buf))
                        continue;
 
+               if (le32_to_cpu(trx->magic) == EDIMAX_PS_HEADER_MAGIC) {
+                       if (mtd->read(mtd, off + EDIMAX_PS_HEADER_LEN,
+                           sizeof(buf), &len, buf) || len != sizeof(buf)) {
+                               continue;
+                       } else {
+                               printk(KERN_NOTICE"Found edimax header\n");
+                       }
+               }
+
                /* found a TRX header */
                if (le32_to_cpu(trx->magic) == TRX_MAGIC) {
                        goto found;
@@ -217,7 +235,7 @@ static int erase_write (struct mtd_info *mtd, unsigned long pos,
        remove_wait_queue(&wait_q, &wait);
 
        /*
-        * Next, writhe data to flash.
+        * Next, write data to flash.
         */
 
        ret = mtd->write (mtd, pos, len, &retlen, buf);
@@ -267,9 +285,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
 {
        struct trx_header trx, *trx2;
        unsigned char buf[512], *block;
-       int off, blocksize;
+       int off, blocksize, trxoff = 0;
        u32 i, crc = ~0;
        size_t len;
+       bool edimax = false;
 
        blocksize = mtd->erasesize;
        if (blocksize < 0x10000)
@@ -285,6 +304,19 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                    len != sizeof(trx))
                        continue;
 
+               /* found an edimax header */
+               if (le32_to_cpu(trx.magic) == EDIMAX_PS_HEADER_MAGIC) {
+                       /* read the correct trx header */
+                       if (mtd->read(mtd, off + EDIMAX_PS_HEADER_LEN,
+                           sizeof(trx), &len, (char *) &trx) ||
+                           len != sizeof(trx)) {
+                               continue;
+                       } else {
+                               printk(KERN_NOTICE"Found an edimax ps header\n");
+                               edimax = true;
+                       }
+               }
+
                /* found a TRX header */
                if (le32_to_cpu(trx.magic) == TRX_MAGIC) {
                        part->offset = le32_to_cpu(trx.offsets[2]) ? : 
@@ -293,6 +325,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
 
                        part->size -= part->offset;
                        part->offset += off;
+                       if (edimax) {
+                               off += EDIMAX_PS_HEADER_LEN;
+                               trxoff = EDIMAX_PS_HEADER_LEN;
+                       }
 
                        goto found;
                }
@@ -304,6 +340,7 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
        return -1;
 
  found:
+       printk(KERN_NOTICE"TRX offset : %lx\n", trxoff);
        if (part->size == 0)
                return 0;
        
@@ -328,7 +365,7 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                /* read first eraseblock from the trx */
                block = kmalloc(mtd->erasesize, GFP_KERNEL);
                trx2 = (struct trx_header *) block;
-               if (mtd->read(mtd, off, mtd->erasesize, &len, block) || len != mtd->erasesize) {
+               if (mtd->read(mtd, off - trxoff, mtd->erasesize, &len, block) || len != mtd->erasesize) {
                        printk("Error accessing the first trx eraseblock\n");
                        return 0;
                }
@@ -338,10 +375,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                printk("new trx = [0x%08x, 0x%08x, 0x%08x], len=0x%08x crc32=0x%08x\n",   trx.offsets[0],   trx.offsets[1],   trx.offsets[2],   trx.len, trx.crc32);
 
                /* Write updated trx header to the flash */
-               memcpy(block, &trx, sizeof(trx));
+               memcpy(block + trxoff, &trx, sizeof(trx));
                if (mtd->unlock)
-                       mtd->unlock(mtd, off, mtd->erasesize);
-               erase_write(mtd, off, mtd->erasesize, block);
+                       mtd->unlock(mtd, off - trxoff, mtd->erasesize);
+               erase_write(mtd, off - trxoff, mtd->erasesize, block);
                if (mtd->sync)
                        mtd->sync(mtd);
                kfree(block);
index 3159bf3f64f72ec553e5d12a22da543a6053c83f..4585c4f9ee8cc5d9cc58d2661e3c6c38c85c300a 100644 (file)
@@ -71,6 +71,15 @@ struct trx_header {
        u32 offsets[TRX_MAX_OFFSET];    /* Offsets of partitions from start of header */
 };
 
+/* for Edimax Print servers which use an additional header
+ * then the firmware on flash looks like :
+ * EDIMAX HEADER | TRX HEADER
+ * As this header is 12 bytes long we have to handle it
+ * and skip it to find the TRX header
+ */
+#define EDIMAX_PS_HEADER_MAGIC 0x36315350 /*  "PS16"  */
+#define EDIMAX_PS_HEADER_LEN   0xc /* 12 bytes long for edimax header */
+
 #define ROUNDUP(x, y) ((((x)+((y)-1))/(y))*(y))
 #define NVRAM_SPACE 0x8000
 #define WINDOW_ADDR 0x1fc00000
@@ -145,6 +154,15 @@ find_cfe_size(struct mtd_info *mtd, size_t size)
                    len != sizeof(buf))
                        continue;
 
+               if (le32_to_cpu(trx->magic) == EDIMAX_PS_HEADER_MAGIC) {
+                       if (mtd->read(mtd, off + EDIMAX_PS_HEADER_LEN,
+                           sizeof(buf), &len, buf) || len != sizeof(buf)) {
+                               continue;
+                       } else {
+                               printk(KERN_NOTICE"Found edimax header\n");
+                       }
+               }
+
                /* found a TRX header */
                if (le32_to_cpu(trx->magic) == TRX_MAGIC) {
                        goto found;
@@ -217,7 +235,7 @@ static int erase_write (struct mtd_info *mtd, unsigned long pos,
        remove_wait_queue(&wait_q, &wait);
 
        /*
-        * Next, writhe data to flash.
+        * Next, write data to flash.
         */
 
        ret = mtd->write (mtd, pos, len, &retlen, buf);
@@ -267,9 +285,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
 {
        struct trx_header trx, *trx2;
        unsigned char buf[512], *block;
-       int off, blocksize;
+       int off, blocksize, trxoff = 0;
        u32 i, crc = ~0;
        size_t len;
+       bool edimax = false;
 
        blocksize = mtd->erasesize;
        if (blocksize < 0x10000)
@@ -285,6 +304,19 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                    len != sizeof(trx))
                        continue;
 
+               /* found an edimax header */
+               if (le32_to_cpu(trx.magic) == EDIMAX_PS_HEADER_MAGIC) {
+                       /* read the correct trx header */
+                       if (mtd->read(mtd, off + EDIMAX_PS_HEADER_LEN,
+                           sizeof(trx), &len, (char *) &trx) ||
+                           len != sizeof(trx)) {
+                               continue;
+                       } else {
+                               printk(KERN_NOTICE"Found an edimax ps header\n");
+                               edimax = true;
+                       }
+               }
+
                /* found a TRX header */
                if (le32_to_cpu(trx.magic) == TRX_MAGIC) {
                        part->offset = le32_to_cpu(trx.offsets[2]) ? : 
@@ -293,6 +325,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
 
                        part->size -= part->offset;
                        part->offset += off;
+                       if (edimax) {
+                               off += EDIMAX_PS_HEADER_LEN;
+                               trxoff = EDIMAX_PS_HEADER_LEN;
+                       }
 
                        goto found;
                }
@@ -304,6 +340,7 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
        return -1;
 
  found:
+       printk(KERN_NOTICE"TRX offset : %lx\n", trxoff);
        if (part->size == 0)
                return 0;
        
@@ -328,7 +365,7 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                /* read first eraseblock from the trx */
                block = kmalloc(mtd->erasesize, GFP_KERNEL);
                trx2 = (struct trx_header *) block;
-               if (mtd->read(mtd, off, mtd->erasesize, &len, block) || len != mtd->erasesize) {
+               if (mtd->read(mtd, off - trxoff, mtd->erasesize, &len, block) || len != mtd->erasesize) {
                        printk("Error accessing the first trx eraseblock\n");
                        return 0;
                }
@@ -338,10 +375,10 @@ find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
                printk("new trx = [0x%08x, 0x%08x, 0x%08x], len=0x%08x crc32=0x%08x\n",   trx.offsets[0],   trx.offsets[1],   trx.offsets[2],   trx.len, trx.crc32);
 
                /* Write updated trx header to the flash */
-               memcpy(block, &trx, sizeof(trx));
+               memcpy(block + trxoff, &trx, sizeof(trx));
                if (mtd->unlock)
-                       mtd->unlock(mtd, off, mtd->erasesize);
-               erase_write(mtd, off, mtd->erasesize, block);
+                       mtd->unlock(mtd, off - trxoff, mtd->erasesize);
+               erase_write(mtd, off - trxoff, mtd->erasesize, block);
                if (mtd->sync)
                        mtd->sync(mtd);
                kfree(block);
index f8c09b97d440179c5a8e7003795fc9ec266ac28a..034200c50a088c2b1044238f1dfff184a9bb05a7 100644 (file)
@@ -49,6 +49,10 @@ define Image/Build/USR
        $(STAGING_DIR_HOST)/bin/trx2usr $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/openwrt-$(2)-$(3).bin
 endef
 
+define Image/Build/Edi
+       $(STAGING_DIR_HOST)/bin/trx2edips $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/openwrt-$(2)-$(3).bin
+endef
+
 define trxalign/jffs2-128k
 -a 0x20000 -f $(KDIR)/root.$(1)
 endef
@@ -87,6 +91,7 @@ define Image/Build/jffs2-64k
        $(call Image/Build/CyberTAN,$(1),wrt350n_v1,EWCG,1.04.1,$(patsubst jffs2-%,jffs2,$(1)))
        $(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
        $(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))
+       $(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
 endef
 
 define Image/Build/squashfs
index ce2876a3047ebfdf086e92c717a9c3540465b8cd..05681b152d4bd366b76178d91761744e413008a2 100644 (file)
@@ -87,6 +87,9 @@ struct trx_header {
        unsigned int offsets[3];        /* Offsets of partitions from start of header */
 };
 
+#define EDIMAX_PS_HEADER_MAGIC 0x36315350 /*  "PS16"  */
+#define EDIMAX_PS_HEADER_LEN   0xc /* 12 bytes long for edimax header */
+
 /* beyound the image end, size not known in advance */
 extern unsigned char workspace[];
 
@@ -135,8 +138,12 @@ void entry(unsigned long icache_size, unsigned long icache_lsize,
 
        /* look for trx header, 32-bit data access */
        for (data = ((unsigned char *) KSEG1ADDR(BCM4710_FLASH));
-               ((struct trx_header *)data)->magic != TRX_MAGIC; data += 65536);
+               ((struct trx_header *)data)->magic != TRX_MAGIC &&
+               ((struct trx_header *)data)->magic != EDIMAX_PS_HEADER_MAGIC;
+                data += 65536);
 
+       if (((struct trx_header *)data)->magic == EDIMAX_PS_HEADER_MAGIC)
+               data += EDIMAX_PS_HEADER_LEN;
        /* compressed kernel is in the partition 0 or 1 */
        if (((struct trx_header *)data)->offsets[1] > 65536) 
                data += ((struct trx_header *)data)->offsets[0];
diff --git a/target/linux/brcm47xx/profiles/PS-1208MFG.mk b/target/linux/brcm47xx/profiles/PS-1208MFG.mk
new file mode 100644 (file)
index 0000000..e17e0ec
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ps1208mfg
+  NAME:=Edimax PS-1208MFG
+  PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-mini block-hotplug kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -kmod-switch kmod-fs-ext4 block-extroot
+endef
+
+define Profile/Ps1208mfg/Description
+       Package set optimize for edimax PS-1208MFG printserver
+endef
+
+$(eval $(call Profile,Ps1208mfg))
+
index eb42f630f7ff569934c9cc91fd36473117cf4620..40b01997b87f2aac1d7376908dcbf4bfafbfca99 100644 (file)
@@ -47,6 +47,7 @@ define Host/Compile
        $(call cc,mktitanimg)
        $(call cc,mkchkimg)
        $(call cc,mkzcfw cyg_crc32)
+       $(call cc,trx2edips)
 endef
 
 define Host/Install
diff --git a/tools/firmware-utils/src/trx2edips.c b/tools/firmware-utils/src/trx2edips.c
new file mode 100644 (file)
index 0000000..9606bd8
--- /dev/null
@@ -0,0 +1,151 @@
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <stdint.h>
+#include <string.h>
+#include <errno.h>
+#include <unistd.h>
+/**********************************************************************/
+/* from trxhdr.h */
+
+#define TRX_MAGIC      0x30524448      /* "HDR0" */
+#define TRX_VERSION    1
+#define TRX_MAX_LEN    0x5A0000
+#define TRX_NO_HEADER  1               /* Do not write TRX header */
+
+struct trx_header {
+       uint32_t magic;                 /* "HDR0" */
+       uint32_t len;                   /* Length of file including header */
+       uint32_t crc32;                 /* 32-bit CRC from flag_version to end of file */
+       uint32_t flag_version;  /* 0:15 flags, 16:31 version */
+       uint32_t offsets[3];    /* Offsets of partitions from start of header */
+};
+
+
+
+#define EDIMAX_PS16    0x36315350
+#define EDIMAX_HDR_LEN 0xc
+
+
+/**********************************************************************/
+static const uint32_t crc_32_tab[] = { /* CRC polynomial 0xedb88320 */
+0x00000000, 0x77073096, 0xee0e612c, 0x990951ba, 0x076dc419, 0x706af48f,
+0xe963a535, 0x9e6495a3, 0x0edb8832, 0x79dcb8a4, 0xe0d5e91e, 0x97d2d988,
+0x09b64c2b, 0x7eb17cbd, 0xe7b82d07, 0x90bf1d91, 0x1db71064, 0x6ab020f2,
+0xf3b97148, 0x84be41de, 0x1adad47d, 0x6ddde4eb, 0xf4d4b551, 0x83d385c7,
+0x136c9856, 0x646ba8c0, 0xfd62f97a, 0x8a65c9ec, 0x14015c4f, 0x63066cd9,
+0xfa0f3d63, 0x8d080df5, 0x3b6e20c8, 0x4c69105e, 0xd56041e4, 0xa2677172,
+0x3c03e4d1, 0x4b04d447, 0xd20d85fd, 0xa50ab56b, 0x35b5a8fa, 0x42b2986c,
+0xdbbbc9d6, 0xacbcf940, 0x32d86ce3, 0x45df5c75, 0xdcd60dcf, 0xabd13d59,
+0x26d930ac, 0x51de003a, 0xc8d75180, 0xbfd06116, 0x21b4f4b5, 0x56b3c423,
+0xcfba9599, 0xb8bda50f, 0x2802b89e, 0x5f058808, 0xc60cd9b2, 0xb10be924,
+0x2f6f7c87, 0x58684c11, 0xc1611dab, 0xb6662d3d, 0x76dc4190, 0x01db7106,
+0x98d220bc, 0xefd5102a, 0x71b18589, 0x06b6b51f, 0x9fbfe4a5, 0xe8b8d433,
+0x7807c9a2, 0x0f00f934, 0x9609a88e, 0xe10e9818, 0x7f6a0dbb, 0x086d3d2d,
+0x91646c97, 0xe6635c01, 0x6b6b51f4, 0x1c6c6162, 0x856530d8, 0xf262004e,
+0x6c0695ed, 0x1b01a57b, 0x8208f4c1, 0xf50fc457, 0x65b0d9c6, 0x12b7e950,
+0x8bbeb8ea, 0xfcb9887c, 0x62dd1ddf, 0x15da2d49, 0x8cd37cf3, 0xfbd44c65,
+0x4db26158, 0x3ab551ce, 0xa3bc0074, 0xd4bb30e2, 0x4adfa541, 0x3dd895d7,
+0xa4d1c46d, 0xd3d6f4fb, 0x4369e96a, 0x346ed9fc, 0xad678846, 0xda60b8d0,
+0x44042d73, 0x33031de5, 0xaa0a4c5f, 0xdd0d7cc9, 0x5005713c, 0x270241aa,
+0xbe0b1010, 0xc90c2086, 0x5768b525, 0x206f85b3, 0xb966d409, 0xce61e49f,
+0x5edef90e, 0x29d9c998, 0xb0d09822, 0xc7d7a8b4, 0x59b33d17, 0x2eb40d81,
+0xb7bd5c3b, 0xc0ba6cad, 0xedb88320, 0x9abfb3b6, 0x03b6e20c, 0x74b1d29a,
+0xead54739, 0x9dd277af, 0x04db2615, 0x73dc1683, 0xe3630b12, 0x94643b84,
+0x0d6d6a3e, 0x7a6a5aa8, 0xe40ecf0b, 0x9309ff9d, 0x0a00ae27, 0x7d079eb1,
+0xf00f9344, 0x8708a3d2, 0x1e01f268, 0x6906c2fe, 0xf762575d, 0x806567cb,
+0x196c3671, 0x6e6b06e7, 0xfed41b76, 0x89d32be0, 0x10da7a5a, 0x67dd4acc,
+0xf9b9df6f, 0x8ebeeff9, 0x17b7be43, 0x60b08ed5, 0xd6d6a3e8, 0xa1d1937e,
+0x38d8c2c4, 0x4fdff252, 0xd1bb67f1, 0xa6bc5767, 0x3fb506dd, 0x48b2364b,
+0xd80d2bda, 0xaf0a1b4c, 0x36034af6, 0x41047a60, 0xdf60efc3, 0xa867df55,
+0x316e8eef, 0x4669be79, 0xcb61b38c, 0xbc66831a, 0x256fd2a0, 0x5268e236,
+0xcc0c7795, 0xbb0b4703, 0x220216b9, 0x5505262f, 0xc5ba3bbe, 0xb2bd0b28,
+0x2bb45a92, 0x5cb36a04, 0xc2d7ffa7, 0xb5d0cf31, 0x2cd99e8b, 0x5bdeae1d,
+0x9b64c2b0, 0xec63f226, 0x756aa39c, 0x026d930a, 0x9c0906a9, 0xeb0e363f,
+0x72076785, 0x05005713, 0x95bf4a82, 0xe2b87a14, 0x7bb12bae, 0x0cb61b38,
+0x92d28e9b, 0xe5d5be0d, 0x7cdcefb7, 0x0bdbdf21, 0x86d3d2d4, 0xf1d4e242,
+0x68ddb3f8, 0x1fda836e, 0x81be16cd, 0xf6b9265b, 0x6fb077e1, 0x18b74777,
+0x88085ae6, 0xff0f6a70, 0x66063bca, 0x11010b5c, 0x8f659eff, 0xf862ae69,
+0x616bffd3, 0x166ccf45, 0xa00ae278, 0xd70dd2ee, 0x4e048354, 0x3903b3c2,
+0xa7672661, 0xd06016f7, 0x4969474d, 0x3e6e77db, 0xaed16a4a, 0xd9d65adc,
+0x40df0b66, 0x37d83bf0, 0xa9bcae53, 0xdebb9ec5, 0x47b2cf7f, 0x30b5ffe9,
+0xbdbdf21c, 0xcabac28a, 0x53b39330, 0x24b4a3a6, 0xbad03605, 0xcdd70693,
+0x54de5729, 0x23d967bf, 0xb3667a2e, 0xc4614ab8, 0x5d681b02, 0x2a6f2b94,
+0xb40bbe37, 0xc30c8ea1, 0x5a05df1b, 0x2d02ef8d
+};
+
+#define UPDC32(octet, crc) (crc_32_tab[((crc) ^ (octet)) & 0xff] ^ ((crc) >> 8))
+
+uint32_t crc32buf(char *buf, size_t len)
+{
+       uint32_t crc;
+
+       crc = 0xFFFFFFFF;
+
+       for (; len; --len, ++buf)
+               crc = UPDC32(*buf, crc);
+
+       return crc;
+}
+
+
+int main(int argc, char *argv[])
+{
+       FILE *fpIn = NULL;
+       FILE *fpOut = NULL;
+       long  nImgSize;
+       uint32_t sign = EDIMAX_PS16;    /* signature for header */
+       uint32_t start_addr = 0x80500000; /* start address but doesn't seems to be used... */
+       uint32_t length; /* length of data, not used too ...*/
+       size_t res;
+
+       char *buf;
+       struct trx_header *p;
+
+
+       if (argc != 3) {
+               printf("Usage: %s <input file> <output file>\n", argv[0]);
+               return -1;
+       }
+
+       fpIn = fopen(argv[1], "rb");
+       if (fpIn == NULL) {
+               fprintf(stderr, "Unable to open %s\n", argv[1]);
+               return EXIT_FAILURE;
+       }
+       fseek(fpIn, 0, SEEK_END);
+       length = ftell(fpIn);
+
+       buf = (char *)malloc(length);
+       if (!buf) {
+               fprintf(stderr, "malloc of buffers failed\n");
+               return EXIT_FAILURE;
+       }
+
+       rewind(fpIn);
+       res = fread(buf, 1, length, fpIn);
+
+       p = (struct trx_header *)buf;
+       if (p->magic != TRX_MAGIC) {
+               fprintf(stderr, "Not a trx file...%x\n", p->magic);
+               return EXIT_FAILURE;
+       }
+
+       fclose(fpIn);
+
+       fpOut = fopen(argv[2], "wb+");
+       if (fpOut == NULL) {
+               fprintf(stderr, "Unable to open %s\n", argv[2]);
+               return EXIT_FAILURE;
+       }
+       /* make the 3 partition beeing 12 bytes closer from the header */
+       memcpy(buf + p->offsets[2] - EDIMAX_HDR_LEN, buf + p->offsets[2], length - p->offsets[2]);
+       p->crc32 = crc32buf((char *) &p->flag_version, length - offsetof(struct trx_header, flag_version));
+
+       fwrite(&sign,  sizeof(long), 1, fpOut);
+       fwrite(&length, sizeof(long), 1, fpOut);
+       fwrite(&start_addr, sizeof(long), 1, fpOut);
+       fwrite(buf, sizeof(char), length, fpOut);
+       fclose(fpOut);
+}
+