openssl: remove some unneeded functionality and algorithms
authorDirk Feytons <dirk.feytons@gmail.com>
Fri, 20 May 2016 13:34:02 +0000 (15:34 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sat, 23 Jul 2016 10:09:51 +0000 (12:09 +0200)
The patch needed for this commit has been sent upstream:
https://github.com/openssl/openssl/pull/1155

Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
Signed-off-by: Felix Fietkau <nbd@nbd.name> [add back bf and srp]
package/libs/openssl/Makefile
package/libs/openssl/patches/302-fix_no_cmac_build.patch [new file with mode: 0644]

index 7cd306ba6346390634c6dccff50905a0c7e2a88f..8e439e1c31b69a76ba9963294ebbb4d9f5628e1e 100644 (file)
@@ -95,8 +95,9 @@ This package contains the OpenSSL command-line utility.
 endef
 
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5
-OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5 \
+ no-whrlpool no-whirlpool no-ripemd no-seed no-cast no-cmac
+OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2 no-ssl2-method no-heartbeats
 
 ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
   OPENSSL_OPTIONS += -DHAVE_CRYPTODEV
@@ -116,7 +117,7 @@ ifndef CONFIG_OPENSSL_WITH_EC2M
 endif
 
 ifndef CONFIG_OPENSSL_WITH_SSL3
-  OPENSSL_OPTIONS += no-ssl3
+  OPENSSL_OPTIONS += no-ssl3 no-ssl3-method
 endif
 
 ifndef CONFIG_OPENSSL_HARDWARE_SUPPORT
diff --git a/package/libs/openssl/patches/302-fix_no_cmac_build.patch b/package/libs/openssl/patches/302-fix_no_cmac_build.patch
new file mode 100644 (file)
index 0000000..1b94f24
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/crypto/asn1/ameth_lib.c
++++ b/crypto/asn1/ameth_lib.c
+@@ -93,7 +93,9 @@ static const EVP_PKEY_ASN1_METHOD *stand
+     &eckey_asn1_meth,
+ #endif
+     &hmac_asn1_meth,
++#ifndef OPENSSL_NO_CMAC
+     &cmac_asn1_meth,
++#endif
+ #ifndef OPENSSL_NO_DH
+     &dhx_asn1_meth
+ #endif
+--- a/crypto/evp/pmeth_lib.c
++++ b/crypto/evp/pmeth_lib.c
+@@ -91,7 +91,9 @@ static const EVP_PKEY_METHOD *standard_m
+     &ec_pkey_meth,
+ #endif
+     &hmac_pkey_meth,
++#ifndef OPENSSL_NO_CMAC
+     &cmac_pkey_meth,
++#endif
+ #ifndef OPENSSL_NO_DH
+     &dhx_pkey_meth
+ #endif