hostapd: fix OWE settings in client mode
authorJo-Philipp Wich <jo@mein.io>
Fri, 20 Sep 2019 09:40:52 +0000 (11:40 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 20 Sep 2019 11:27:21 +0000 (13:27 +0200)
This changes fixes the generation of the wpa_supplicant client configuration
in WPA3 OWE client mode. Instead of incorrectly emitting key_mgmt=NONE, use
the proper key_mgmt=OWE setting instead.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index 233ef389ae50e13d42e2ec9cfeecfb6e2ee462a5..e94d66211d9f59488b6dca205a7adf9ed3310ef8 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 46acbefeeeb771de879dd9926ad170042dff2473..c7f3ea2c1e2dda10a5bceeaa95310630d866a76f 100644 (file)
@@ -788,6 +788,7 @@ wpa_supplicant_add_network() {
                none) ;;
                owe)
                        hostapd_append_wpa_key_mgmt
+                       key_mgmt="$wpa_key_mgmt"
                ;;
                wep)
                        local wep_keyidx=0