ath79: add support for TP-Link TL-WR841N/ND v10
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 22 Jul 2019 15:34:08 +0000 (17:34 +0200)
committerDavid Bauer <mail@david-bauer.net>
Mon, 5 Aug 2019 08:54:11 +0000 (10:54 +0200)
The TL-WR841N/ND v10 is mostly identical to the v9. Apart from some minor
changes, it contains a newer revision of the QCA9533 SoC and the CPU clock
is significantly higher.

Flash instruction (WebUI):
Download *-factory.bin image and upload it via the firmwary upgrade
function of the stock firmware WebUI.

Flash instruction (TFTP):
1. Set PC to fixed ip address 192.168.0.66
2. Download *-factory.bin image and rename it to wr841nv10_tp_recovery.bin
3. Start a tftp server with the image file in its root directory
4. Turn off the router
5. Press and hold Reset button
6. Turn on router with the reset button pressed and wait ~15 seconds
7. Release the reset button and after a short time
the firmware should be transferred from the tftp server
8. Wait ~30 second to complete recovery.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/qca9533_tplink_tl-wr841-v10.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_tplink_tl-wr841-v9.dts
target/linux/ath79/image/tiny-tp-link.mk

index d68c1ee9efec59d8692828a86bc5d9f4e69c81af..407c991d21f73fa18c3b971de28144cfb2552ba4 100755 (executable)
@@ -135,6 +135,7 @@ tplink,archer-c6-v2)
        ;;
 tplink,archer-c25-v1|\
 tplink,tl-wr841-v9|\
+tplink,tl-wr841-v10|\
 tplink,tl-wr841-v11|\
 tplink,tl-wr842n-v3)
        ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
index beac4660d25c11b73332515d69148d25ea7f80d8..49e599f343c4b0afd4cb2d3c229d6c1c804bdd1f 100755 (executable)
@@ -83,6 +83,7 @@ ath79_setup_interfaces()
        tplink,tl-mr3420-v1|\
        tplink,tl-wr841-v7|\
        tplink,tl-wr841-v9|\
+       tplink,tl-wr841-v10|\
        tplink,tl-wr841-v11|\
        tplink,tl-wr842n-v1|\
        tplink,tl-wr842n-v3|\
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr841-v10.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr841-v10.dts
new file mode 100644 (file)
index 0000000..2a4d0a1
--- /dev/null
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_tl-wr841.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr841-v10", "qca,qca9533";
+       model = "TP-Link TL-WR841N/ND v10";
+
+       aliases {
+               led-boot = &qss_led;
+               led-failsafe = &qss_led;
+               led-running = &qss_led;
+               led-upgrade = &qss_led;
+       };
+};
index a3284226a04b9ad3e15ba1098556399fdb404c7b..d8c4546f494665e994dd008003e5805fda3bd81f 100644 (file)
@@ -1,9 +1,6 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /dts-v1/;
 
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
 #include "qca9533_tplink_tl-wr841.dtsi"
 
 / {
index cc9065e92bcc672c0c9656eb162979e22889992d..73c69996690f8d229e01d46257361f0510bbfa6a 100644 (file)
@@ -168,6 +168,15 @@ define Device/tplink_tl-wr841-v9
 endef
 TARGET_DEVICES += tplink_tl-wr841-v9
 
+define Device/tplink_tl-wr841-v10
+  $(Device/tplink-4mlzma)
+  ATH_SOC := qca9533
+  DEVICE_MODEL := TL-WR841N/ND
+  DEVICE_VARIANT := v10
+  TPLINK_HWID := 0x08410010
+endef
+TARGET_DEVICES += tplink_tl-wr841-v10
+
 define Device/tplink_tl-wr841-v11
   $(Device/tplink-4mlzma)
   ATH_SOC := qca9533