ath79: move 5.15 testing kernel to common Makefile
authorNick Hainke <vincent@systemli.org>
Tue, 23 Aug 2022 17:14:47 +0000 (19:14 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 6 Sep 2022 00:57:35 +0000 (02:57 +0200)
All subtargets are using now 5.15 as testing kernel.
Move KERNEL_TESTING_PATCHVER:=5.15 to the common Makefile.

Signed-off-by: Nick Hainke <vincent@systemli.org>
target/linux/ath79/Makefile
target/linux/ath79/generic/target.mk
target/linux/ath79/mikrotik/target.mk
target/linux/ath79/nand/target.mk
target/linux/ath79/tiny/target.mk

index dd57d9fed9311aed1216b2a50f3df400884ec218..20dae789af19f4a7813ceaa5f0ec44327e34d43c 100644 (file)
@@ -9,6 +9,7 @@ SUBTARGETS:=generic mikrotik nand tiny
 FEATURES:=ramdisk squashfs usbgadget
 
 KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
index af330b09b8d68db0286921049414025508ed0abf..4e53c8926053dc1ef9bc3ac6ac56b82d927ae16e 100644 (file)
@@ -2,8 +2,6 @@ BOARDNAME:=Generic
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.15
-
 define Target/Description
        Build firmware images for generic Atheros AR71xx/AR913x/AR934x based boards.
 endef
index 697aa003c82c8bb274d6f8b904656ac3e135db81..f5df904487506034e82259738045c2916badbe87 100644 (file)
@@ -5,8 +5,6 @@ IMAGES_DIR := ../../..
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.15
-
 define Target/Description
        Build firmware images for MikroTik devices based on Qualcomm Atheros
        MIPS SoCs (AR71xx, AR72xx, AR91xx, AR93xx, QCA95xx).
index 12694b6013e758ad2dfea3793f49ccf9681511d5..7ea9b57f45d5fb991a8f76b2236213af25d297e5 100644 (file)
@@ -4,8 +4,6 @@ FEATURES += nand
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.15
-
 define Target/Description
        Firmware for boards using Qualcomm Atheros, MIPS-based SoCs
        in the ar72xx and subsequent series, with support for NAND flash
index 8241aacd3a75fe24e49e8bf872d55c6aad398ab4..28e02f7a674c434abd1da7a08b145c27822766b4 100644 (file)
@@ -3,8 +3,6 @@ FEATURES += low_mem small_flash
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.15
-
 define Target/Description
        Build firmware images for Atheros AR71xx/AR913x/AR934x based boards with small flash
 endef