Revert "ath79: add empty squashfs-lzma filesystem"
authorDaniel Golle <daniel@makrotopia.org>
Fri, 12 May 2023 00:23:10 +0000 (02:23 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 12 May 2023 00:27:17 +0000 (02:27 +0200)
This reverts commit 91e3419a33f3f0baa2fb25680f5c9a7b2240102b.
Now that squashfs3-lzma generates reproducible output we can drop the
empty binary. Having a binary file in the tree is not nice and we actually
also use squashfs3-lzma for devices which expect the kernel to be loaded
from a squashfs3...

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/image-commands.mk
target/linux/ath79/image/Makefile
target/linux/ath79/image/empty-squashfs-lzma [deleted file]

index e1951672e649c62d4c3cf20bc73173aa1142fbad..0c13f30fef6c9587723b936016d7be929cbc2e63 100644 (file)
@@ -103,6 +103,16 @@ define Build/append-rootfs
        dd if=$(IMAGE_ROOTFS) >> $@
 endef
 
+define Build/append-squashfs-fakeroot-be
+       rm -rf $@.fakefs $@.fakesquashfs
+       mkdir $@.fakefs
+       $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma \
+               $@.fakefs $@.fakesquashfs \
+               -noappend -root-owned -be -nopad -b 65536 \
+               $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+       cat $@.fakesquashfs >> $@
+endef
+
 define Build/append-squashfs4-fakeroot
        rm -rf $@.fakefs $@.fakesquashfs
        mkdir $@.fakefs
index 02fd26bfd8b35be59a1b926c23d2ea7743c75161..8328be7667cf8dd675fc5b4571e1a7a61405c378 100644 (file)
@@ -60,9 +60,6 @@ define Build/relocate-kernel
        rm -rf $@.relocate
 endef
 
-define Build/append-squashfs-fakeroot-be
-       cat ./empty-squashfs-lzma >> $@
-endef
 
 define Device/Default
   DEVICE_DTS_DIR := ../dts
diff --git a/target/linux/ath79/image/empty-squashfs-lzma b/target/linux/ath79/image/empty-squashfs-lzma
deleted file mode 100755 (executable)
index 803a766..0000000
Binary files a/target/linux/ath79/image/empty-squashfs-lzma and /dev/null differ