add Marvell orion watchdog timer module
authorFlorian Fainelli <florian@openwrt.org>
Sun, 20 Feb 2011 17:24:20 +0000 (17:24 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 20 Feb 2011 17:24:20 +0000 (17:24 +0000)
This patch adds kernelmodule for watchdog timer on platform orion.

Signed-off-by: Michael Kämmerer <mrk_at_h3c_._de>
SVN-Revision: 25620

package/kernel/modules/other.mk

index f6e6ea3990aefe07a7ed19feae2286f57135c91e..56cda45f701cd3d9ffa46f1d8be58bf3e77091c3 100644 (file)
@@ -770,6 +770,22 @@ endef
 $(eval $(call KernelPackage,wdt-omap))
 
 
+define KernelPackage/wdt-orion
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Marvell Orion Watchdog timer
+  DEPENDS:=@TARGET_orion
+  KCONFIG:=CONFIG_ORION_WATCHDOG
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
+endef
+
+define KernelPackage/wdt-orion/description
+  Kernel module for Marvell orion watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-orion))
+
+
 define KernelPackage/wdt-sc520
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Natsemi SC520 Watchdog support