iproute2: fix broken configuration patch
authorTony Ambardar <itugrok@yahoo.com>
Fri, 23 Nov 2018 09:09:23 +0000 (01:09 -0800)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 11 Feb 2019 20:18:48 +0000 (20:18 +0000)
Since v4.13, iproute2 switched to a config.mk file with greater use of
pkg-config for library/feature detection. Replace the old Config patch
with one modifying the configure script but enabling the same changes:
 - explicitly disable TC_CONFIG_ATM
 - rely on feature detection for IP_CONFIG_SETNS and TC_CONFIG_XT

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/network/utils/iproute2/patches/100-config.patch [deleted file]
package/network/utils/iproute2/patches/100-configure.patch [new file with mode: 0644]

diff --git a/package/network/utils/iproute2/patches/100-config.patch b/package/network/utils/iproute2/patches/100-config.patch
deleted file mode 100644 (file)
index 7f23cfc..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
---- /dev/null
-+++ b/Config
-@@ -0,0 +1,4 @@
-+# Fixed config to disable ATM support even if present on host system
-+IP_CONFIG_SETNS:=y
-+TC_CONFIG_ATM:=n
-+TC_CONFIG_XT:=y
diff --git a/package/network/utils/iproute2/patches/100-configure.patch b/package/network/utils/iproute2/patches/100-configure.patch
new file mode 100644 (file)
index 0000000..248b1c0
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/configure
++++ b/configure
+@@ -32,7 +32,8 @@ int main(int argc, char **argv) {
+ }
+ EOF
+-    if $CC -I$INCLUDE -o $TMPDIR/atmtest $TMPDIR/atmtest.c -latm >/dev/null 2>&1; then
++# OpenWrt: disable ATM support even if present on host system
++    if [ 1 -eq 0 ]; then
+       echo "TC_CONFIG_ATM:=y" >>$CONFIG
+       echo yes
+     else