Makefile: add a check to bail out early when the path to the openwrt directory contai...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 21 Oct 2012 02:00:11 +0000 (02:00 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 21 Oct 2012 02:00:11 +0000 (02:00 +0000)
SVN-Revision: 33884

Makefile

index 348e64500592d502b100ec2e5cb9fe96d6534f2d..5257a990dcc6c6ab818489759aa8679ca3253ea4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,10 @@ LC_ALL:=C
 LANG:=C
 export TOPDIR LC_ALL LANG
 
+empty:=
+space:= $(empty) $(empty)
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+
 world:
 
 include $(TOPDIR)/include/host.mk