uClibc: enhance debug support (closes: #6118)
authorNicolas Thill <nico@openwrt.org>
Sun, 7 Mar 2010 15:10:57 +0000 (15:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 7 Mar 2010 15:10:57 +0000 (15:10 +0000)
SVN-Revision: 20031

toolchain/uClibc/Makefile
toolchain/uClibc/config-0.9.30+nptl/debug [new file with mode: 0644]
toolchain/uClibc/config-0.9.30.1/debug [new file with mode: 0644]
toolchain/uClibc/config-0.9.30.2/debug [new file with mode: 0644]

index b94fc2e71e646104563cce0de9bb891f1f9ad7d9..25fd09f832a42f9ae54df184c32b05c70a564669 100644 (file)
@@ -58,7 +58,10 @@ define Host/SetToolchainInfo
        $(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(LIBC_SO_VERSION),' $(TOOLCHAIN_DIR)/info.mk
 endef
 
-GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
+       $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) \
+       $(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
+       $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
 
 define Host/Prepare
        $(call Host/SetToolchainInfo)
@@ -100,10 +103,6 @@ UCLIBC_MAKE = PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
        LIBGCC="$(subst libgcc.a,libgcc_initial.a,$(shell $(TARGET_CC) -print-libgcc-file-name))" \
        DOSTRIP=""
 
-ifeq ($(CONFIG_UCLIBC_ENABLE_DEBUG),y)
-       UCLIBC_MAKE += DODEBUG=y
-endif
-
 define Host/Compile
        $(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(HOST_BUILD_DIR)/Rules.mak
        $(UCLIBC_MAKE) PREFIX= all
diff --git a/toolchain/uClibc/config-0.9.30+nptl/debug b/toolchain/uClibc/config-0.9.30+nptl/debug
new file mode 100644 (file)
index 0000000..b366e66
--- /dev/null
@@ -0,0 +1,6 @@
+DODEBUG=y
+DODEBUG_PT=y
+PTHREADS_DEBUG_SUPPORT=y
+SUPPORT_LD_DEBUG=y
+SUPPORT_LD_DEBUG_EARLY=y
+UCLIBC_MALLOC_DEBUGGING=y
diff --git a/toolchain/uClibc/config-0.9.30.1/debug b/toolchain/uClibc/config-0.9.30.1/debug
new file mode 100644 (file)
index 0000000..b366e66
--- /dev/null
@@ -0,0 +1,6 @@
+DODEBUG=y
+DODEBUG_PT=y
+PTHREADS_DEBUG_SUPPORT=y
+SUPPORT_LD_DEBUG=y
+SUPPORT_LD_DEBUG_EARLY=y
+UCLIBC_MALLOC_DEBUGGING=y
diff --git a/toolchain/uClibc/config-0.9.30.2/debug b/toolchain/uClibc/config-0.9.30.2/debug
new file mode 100644 (file)
index 0000000..b366e66
--- /dev/null
@@ -0,0 +1,6 @@
+DODEBUG=y
+DODEBUG_PT=y
+PTHREADS_DEBUG_SUPPORT=y
+SUPPORT_LD_DEBUG=y
+SUPPORT_LD_DEBUG_EARLY=y
+UCLIBC_MALLOC_DEBUGGING=y