mac80211: pass down noscan to wpa_supplicant
authorDaniel Golle <daniel@makrotopia.org>
Fri, 20 Apr 2018 05:39:10 +0000 (07:39 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 20 Apr 2018 05:52:19 +0000 (07:52 +0200)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/mac80211/Makefile
package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh

index 8656e536a0ef342d1ee16acbadcb17129ad8b314..f3e4d79c80e500a3becc4865cf65ff441f65ad7e 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2017-11-01
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_HASH:=8437ab7886b988c8152e7a4db30b7f41009e49a3b2cb863edd05da1ecd7eb05a
 
index bf9d52ae4203c294e25487f1678cfcd25e7a1dce..16e32a91a482c86334cfb28f71e34f956a9684f6 100644 (file)
@@ -524,7 +524,7 @@ mac80211_setup_supplicant() {
 
 mac80211_setup_supplicant_noctl() {
        wpa_supplicant_prepare_interface "$ifname" nl80211 || return 1
-       wpa_supplicant_add_network "$ifname" "$freq" "$htmode"
+       wpa_supplicant_add_network "$ifname" "$freq" "$htmode" "$noscan"
        wpa_supplicant_run "$ifname"
 }