imx6: use ubinize-image.sh to fix build with per-device rootfs
authorFelix Fietkau <nbd@nbd.name>
Sun, 31 Jul 2016 16:34:31 +0000 (18:34 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 31 Jul 2016 17:35:05 +0000 (19:35 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/imx6/image/Makefile
target/linux/imx6/image/ubinize-ventana.cfg [deleted file]
target/linux/imx6/image/ubinize.cfg [deleted file]

index 9122d9673ae16db166632df058131d99ea3a0d03..a7d68fbe977e3e3ab94f2786ccf163b6579ed7a0 100644 (file)
@@ -51,20 +51,10 @@ define Build/ubi-boot-overlay
                $(BIN_DIR)/$(IMG_PREFIX)-$(DEVICE_NAME)-bootfs_$(word 1, $(1)).ubifs
 
        # ubi
                $(BIN_DIR)/$(IMG_PREFIX)-$(DEVICE_NAME)-bootfs_$(word 1, $(1)).ubifs
 
        # ubi
-       rm -rf p $(KDIR)/$(DEVICE_NAME)_$(word 1, $(1))
-       mkdir -p $(KDIR)/$(DEVICE_NAME)_$(word 1, $(1))
-       $(CP) $(word 2, $^) \
-               $(KDIR)/$(DEVICE_NAME)_$(word 1, $(1))/
-       $(CP) $(KDIR)/boot-$(DEVICE_NAME)-bootfs_$(word 1, $(1)).ubifs \
-               $(KDIR)/$(DEVICE_NAME)_$(word 1, $(1))/boot.ubifs
-       $(CP) ./ubinize-$(DEVICE_NAME).cfg \
-               $(KDIR)/$(DEVICE_NAME)_$(word 1, $(1))/ubinize.cfg
-       ( cd $(KDIR)/$(DEVICE_NAME)_$(word 1, $(1)); \
-               $(STAGING_DIR_HOST)/bin/ubinize \
-               -m $(word 2, $(1)) -p $(word 4, $(1)) -s $(word 2, $(1)) \
-               -o $@ \
-               ubinize.cfg \
-       )
+       sh $(TOPDIR)/scripts/ubinize-image.sh \
+               --part boot=$(KDIR)/boot-$(DEVICE_NAME)-bootfs_$(word 1, $(1)).ubifs=15 \
+               $(IMAGE_ROOTFS) $@ \
+               -m $(word 2, $(1)) -p $(word 4, $(1)) -s $(word 2, $(1))
 endef
 
 define Build/bootfs.tar.gz
 endef
 
 define Build/bootfs.tar.gz
diff --git a/target/linux/imx6/image/ubinize-ventana.cfg b/target/linux/imx6/image/ubinize-ventana.cfg
deleted file mode 100644 (file)
index 6b30b09..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-[boot]
-# Volume mode (other option is static)
-mode=ubi
-# Source image
-image=boot.ubifs
-# Volume ID in UBI image
-vol_id=0
-# Allow for dynamic resize
-vol_type=dynamic
-# Volume name
-vol_name=boot
-vol_size=15MiB
-
-[rootfs]
-# Volume mode (other option is static)
-mode=ubi
-# Source image
-image=root.squashfs
-# Volume ID in UBI image
-vol_id=1
-# Allow for dynamic resize
-vol_type=dynamic
-# Volume name
-vol_name=rootfs
-
-[rootfs_data]
-# Volume mode (other option is static)
-mode=ubi
-# Volume ID in UBI image
-vol_id=2
-# Allow for dynamic resize
-vol_type=dynamic
-# Volume name
-vol_name=rootfs_data
-# Autoresize volume at first mount
-vol_flags=autoresize
-vol_size=1MiB
diff --git a/target/linux/imx6/image/ubinize.cfg b/target/linux/imx6/image/ubinize.cfg
deleted file mode 100644 (file)
index e4149ec..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-[rootfs]
-# Volume mode (other option is static)
-mode=ubi
-# Source image
-image=root.ubifs
-# Volume ID in UBI image
-vol_id=0
-# Allow for dynamic resize
-vol_type=dynamic
-# Volume name
-vol_name=rootfs
-# Autoresize volume at first mount
-vol_flags=autoresize