linux: kmod-zram requires kmod-lib-lz4 for >= 3.15
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 29 Jan 2015 21:59:03 +0000 (21:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 29 Jan 2015 21:59:03 +0000 (21:59 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44205

package/kernel/linux/modules/other.mk

index 59d2e2c..a69d817 100644 (file)
@@ -748,7 +748,7 @@ $(eval $(call KernelPackage,ikconfig))
 define KernelPackage/zram
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ZRAM
-  DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx
+  DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx +(!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13&&!LINUX_3_14):kmod-lib-lz4
   KCONFIG:= \
        CONFIG_ZSMALLOC \
        CONFIG_ZRAM \