gcc: compile libgcc and libstdc++ with -O2 instead of -Os on power pc to avoid genera...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 27 Oct 2009 01:11:35 +0000 (01:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 27 Oct 2009 01:11:35 +0000 (01:11 +0000)
SVN-Revision: 18177

toolchain/gcc/Makefile

index 3b31127b4ae6db6815fc573bc2298de964ba76c1..77243c5fa4bd2c45853a5bee0278b2a5062ed19b 100644 (file)
@@ -151,6 +151,10 @@ GCC_CONFIGURE_STAGE2:= \
                --disable-tls \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifdef CONFIG_powerpc
+  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
+
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \