ppp: compile fix: unset FILTER variable in Makefile
authorEike Ritter <git@rittere.co.uk>
Sun, 14 Mar 2021 18:50:21 +0000 (18:50 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 Mar 2021 23:25:58 +0000 (00:25 +0100)
If the environment variable FILTER is set before compilation,
compilation of the ppp-package will fail with the error message

Package ppp is missing dependencies for the following libraries:
libpcap.so.1

The reason is that the OpenWrt-patch for the Makefile only comments
out the line FILTER=y. Hence the pcap-library will be dynamically
linked if the environment variable FILTER is set elsewhere, which
causes compilation to fail. The fix consists on explicitly unsetting
the variable FILTER instead.

Signed-off-by: Eike Ritter <git@rittere.co.uk>
package/network/services/ppp/patches/610-pppd_compile_fix.patch [new file with mode: 0644]

diff --git a/package/network/services/ppp/patches/610-pppd_compile_fix.patch b/package/network/services/ppp/patches/610-pppd_compile_fix.patch
new file mode 100644 (file)
index 0000000..4f66e5d
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/pppd/Makefile.linux
++++ b/pppd/Makefile.linux
+@@ -49,7 +49,8 @@ MPPE=y
+ # Uncomment the next line to include support for PPP packet filtering.
+ # This requires that the libpcap library and headers be installed
+ # and that the kernel driver support PPP packet filtering.
+-#FILTER=y
++# libpcap statically linked in OpenWRT, hence disabled here.
++FILTER=
+ # Support for precompiled filters
+ PRECOMPILED_FILTER=y