sdcc: drop tool, it is not used since r31227
authorLuka Perkov <luka@openwrt.org>
Tue, 24 Sep 2013 16:21:30 +0000 (16:21 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 24 Sep 2013 16:21:30 +0000 (16:21 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38167

tools/Makefile
tools/sdcc/Makefile [deleted file]
tools/sdcc/patches/100-workaround-gcc-4.6.2-hang.patch [deleted file]
tools/sdcc/patches/200-fix_order_of_linking.patch [deleted file]

index d0dc53bf205ce28d4a778e2b0b9b4ff4ac19ce7f..dab7bc63c2d72807b3ce3c8aa6224d906e46f97d 100644 (file)
@@ -31,10 +31,6 @@ ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSM
 tools-y += b43-tools
 endif
 
-ifneq ($(CONFIG_PACKAGE_firmwarehotplug),)
-tools-y += sdcc
-endif
-
 ifdef CONFIG_GCC_USE_GRAPHITE
   ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
        tools-y += ppl cloog
diff --git a/tools/sdcc/Makefile b/tools/sdcc/Makefile
deleted file mode 100644 (file)
index 3210bb3..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# 
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=sdcc
-PKG_VERSION:=3.0.0
-
-PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=20fbd49a3421e09fe65577c45524c89e
-
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
-HOST_CONFIGURE_ARGS += \
-       --disable-ucsim \
-       --enable-packihx \
-       --enable-sdcpp \
-       --disable-sdcdb \
-       --disable-gbz80-port \
-       --disable-z80-port \
-       --disable-ds390-port \
-       --disable-ds400-port \
-       --disable-pic-port \
-       --disable-pic16-port \
-       --disable-hc08-port \
-       --disable-avr-port \
-       --disable-xa51-port \
-       --enable-mcs51-port \
-       --enable-device-lib \
-
-define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/sdcc/patches/100-workaround-gcc-4.6.2-hang.patch b/tools/sdcc/patches/100-workaround-gcc-4.6.2-hang.patch
deleted file mode 100644 (file)
index 71db14f..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/src/SDCCicode.c
-+++ b/src/SDCCicode.c
-@@ -1130,6 +1130,9 @@ iCode *getBuiltinParms (iCode *ic, int *
-     return ic;
- }
-+#pragma GCC push_options
-+#pragma GCC optimize ("O0")
-+
- /*-----------------------------------------------------------------*/
- /* operandOperation - performs operations on operands             */
- /*-----------------------------------------------------------------*/
-@@ -1405,6 +1408,7 @@ operandOperation (operand * left, operan
-   return retval;
- }
-+#pragma GCC pop_options
- /*-----------------------------------------------------------------*/
diff --git a/tools/sdcc/patches/200-fix_order_of_linking.patch b/tools/sdcc/patches/200-fix_order_of_linking.patch
deleted file mode 100644 (file)
index 6443497..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-diff --git a/sdcc/sdas/as6808/Makefile.in b/sdcc/sdas/as6808/Makefile.in
-index 5041265..0b8732e 100644
---- a/sdas/as6808/Makefile.in
-+++ b/sdas/as6808/Makefile.in
-@@ -36,7 +36,8 @@ VPATH           = @srcdir@
- CPPFLAGS        = @CPPFLAGS@ -DSDCDB -DNOICE -DINDEXLIB -I. -I$(srcdir) -I$(srcdir)/../asxxsrc -I$(srcdir)/../../support/Util
- CFLAGS          = @CFLAGS@ @WALL_FLAG@ $(CPPFLAGS)
--LDFLAGS         = @LDFLAGS@ -lm
-+LDFLAGS         = @LDFLAGS@
-+LIBS            = -lm
- OBJDIR = obj
-@@ -65,7 +66,7 @@ transform       = @program_transform_name@
- all: checkconf $(ASX)
- $(ASX): $(ASOBJECTS)
--      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS) $(LIBS)
- # Compiling and installing everything and running test
- # ----------------------------------------------------
-diff --git a/sdcc/sdas/as8051/Makefile.in b/sdcc/sdas/as8051/Makefile.in
-index 8fa5946..fde3001 100644
---- a/sdas/as8051/Makefile.in
-+++ b/sdas/as8051/Makefile.in
-@@ -36,7 +36,8 @@ VPATH           = @srcdir@
- CPPFLAGS        = @CPPFLAGS@ -DSDCDB -DNOICE -DINDEXLIB -I. -I$(srcdir) -I$(srcdir)/../asxxsrc -I$(srcdir)/../../support/Util
- CFLAGS          = @CFLAGS@ @WALL_FLAG@ $(CPPFLAGS)
--LDFLAGS         = @LDFLAGS@ -lm
-+LDFLAGS         = @LDFLAGS@
-+LIBS            = -lm
- OBJDIR = obj
-@@ -65,7 +66,7 @@ transform       = @program_transform_name@
- all: checkconf $(ASX)
- $(ASX): $(ASOBJECTS)
--      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS) $(LIBS)
- # Compiling and installing everything and running test
- # ----------------------------------------------------
-diff --git a/sdcc/sdas/asgb/Makefile.in b/sdcc/sdas/asgb/Makefile.in
-index 2763b3f..f9afb23 100644
---- a/sdas/asgb/Makefile.in
-+++ b/sdas/asgb/Makefile.in
-@@ -36,7 +36,8 @@ VPATH           = @srcdir@
- CPPFLAGS        = @CPPFLAGS@ -DSDCDB -DNOICE -DINDEXLIB -I. -I$(srcdir) -I$(srcdir)/../asxxsrc -I$(srcdir)/../../support/Util
- CFLAGS          = @CFLAGS@ @WALL_FLAG@ $(CPPFLAGS)
--LDFLAGS         = @LDFLAGS@ -lm
-+LDFLAGS         = @LDFLAGS@
-+LIBS            = -lm
- OBJDIR = obj
-@@ -65,7 +66,7 @@ transform       = @program_transform_name@
- all: checkconf $(ASX)
- $(ASX): $(ASOBJECTS)
--      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS) $(LIBS)
- # Compiling and installing everything and running test
- # ----------------------------------------------------
-diff --git a/sdcc/sdas/asz80/Makefile.in b/sdcc/sdas/asz80/Makefile.in
-index d2bf1ac..89bd91c 100644
---- a/sdas/asz80/Makefile.in
-+++ b/sdas/asz80/Makefile.in
-@@ -36,7 +36,8 @@ VPATH           = @srcdir@
- CPPFLAGS        = @CPPFLAGS@ -DSDCDB -DNOICE -DINDEXLIB -I. -I$(srcdir) -I$(srcdir)/../asxxsrc -I$(srcdir)/../../support/Util
- CFLAGS          = @CFLAGS@ @WALL_FLAG@ $(CPPFLAGS)
--LDFLAGS         = @LDFLAGS@ -lm
-+LDFLAGS         = @LDFLAGS@
-+LIBS            = -lm
- OBJDIR = obj
-@@ -65,7 +66,7 @@ transform       = @program_transform_name@
- all: checkconf $(ASX)
- $(ASX): $(ASOBJECTS)
--      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASOBJECTS) $(LIBS)
- # Compiling and installing everything and running test
- # ----------------------------------------------------